Cannot open OpenVpn on Mac

Official client software for OpenVPN Access Server and OpenVPN Cloud.
Post Reply
OpenVpn Newbie
Posts: 1
Joined: Sun Nov 25, 2018 1:19 am

Cannot open OpenVpn on Mac

Post by natalir » Sun Nov 25, 2018 1:47 am

I have been using OpenVPN for about a year. Suddenly the application failed and since then I can't open the app at all. I have tried uninstalling and installing again, but nothing helps.
  • If I run:

    Code: Select all

    open /Applications/OpenVPN/OpenVPN\
    I get:

    Code: Select all

    LSOpenURLsWithRole() failed with error -10810 for the file /Applications/OpenVPN/OpenVPN
    When I open the system log I see:

    Code: Select all[1] (net.openvpn.OpenVPNConnect.2228[18626]): Service exited with abnormal code: 1
  • If I double-click on the application, nothing happens.
  • If i open the executable within the contents of the app, I get this error:

    Code: Select all

     /Applications/OpenVPN/OpenVPN\ ; exit;
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/Library/Frameworks/OpenVPN.framework/Versions/Current/lib/python2.7/site-packages/pyovpn-2.1-py2.7.egg/pyovpn/mac/", line 34, in <module>
      File "/Library/Frameworks/OpenVPN.framework/Versions/Current/lib/python2.7/site-packages/pyovpn-2.1-py2.7.egg/pyovpn/tray/", line 8, in <module>
      File "/Library/Frameworks/OpenVPN.framework/Versions/Current/lib/python2.7/site-packages/pyovpn-2.1-py2.7.egg/pyovpn/tray/", line 18, in <module>
      File "/Library/Frameworks/OpenVPN.framework/Versions/Current/lib/python2.7/site-packages/pyovpn-2.1-py2.7.egg/pyovpn/util/", line 2, in <module>
      File "/usr/local/lib/python2.7/site-packages/OpenSSL/", line 8, in <module>
        from OpenSSL import crypto, SSL
      File "/usr/local/lib/python2.7/site-packages/OpenSSL/", line 12, in <module>
        from cryptography import x509
      File "/usr/local/lib/python2.7/site-packages/cryptography/x509/", line 7, in <module>
        from cryptography.x509 import certificate_transparency
    ImportError: cannot import name certificate_transparency
Any ideas, suggestions, anything at all is greatly appreciated!!

OpenVpn Newbie
Posts: 1
Joined: Mon Mar 30, 2020 8:19 am

Re: Cannot open OpenVpn on Mac

Post by ganesancit » Mon Mar 30, 2020 8:20 am

Any answers @natalir. I have the same exact issue as well and its driving me crazy

OpenVpn Newbie
Posts: 1
Joined: Tue Dec 07, 2021 3:30 pm

Re: Cannot open OpenVpn on Mac

Post by Andre_SF » Tue Dec 07, 2021 3:31 pm

I am having the same issue. I have uninstalled and reinstalled several times and the app will not launch. It just hangs.

User avatar
OpenVPN Inc.
Posts: 661
Joined: Tue Feb 16, 2021 10:41 am

Re: Cannot open OpenVpn on Mac

Post by openvpn_inc » Sat Dec 11, 2021 10:19 pm


This looks like an error message about OpenVPN Connect v2. That is an outdated program. You should really instead be using OpenVPN Connect v3. I would suggest you install OpenVPN Connect v3 and see if that works as expected. If it doesn't you can contact for support.

Latest version of OpenVPN Connect v3 can be downloaded here:

While Connect v2 is still listed there, it will eventually be removed, as it is an older version.

Kind regards,
Image OpenVPN Inc.
Answers provided by OpenVPN Inc. staff members here are provided on a voluntary best-effort basis, and no rights can be claimed on the basis of answers posted in this public forum. If you wish to get official support from OpenVPN Inc. please use the official support ticket system:

Post Reply