OpenVPN Connect Mac (10.11) Fails: Error running jsondialog

Post Reply
danklopp
OpenVpn Newbie
Posts: 1
Joined: Mon Oct 05, 2015 8:46 pm

OpenVPN Connect Mac (10.11) Fails: Error running jsondialog

Post by danklopp » Mon Oct 05, 2015 8:54 pm

I have recently installed the provided OpenVPN server from the AWS Marketplace. A windows user was able to connect without issue to the VPN server. When I attempted to do so on my Mac, I kept receiving the error "Error running jsondialog". Copied below is the log output of my test. Any help would be appreciated.


Mon Oct 5 13:41:49 2015 TrayClient.connect: (None, u'52.10.154.117', None, True)
Mon Oct 5 13:41:49 2015 found best profile: Profile[id=52_10_154_117_dynamic_p4495,owner=3,host=52.10.154.117,autologin=False,state=0]
Mon Oct 5 13:41:49 2015 >>>> {'cookie': 'TRAY_CLIENT_ZGtsb3Bw_6rEWNYKw', 'state': 'connect', 'profile_id': '52_10_154_117_dynamic_p4495', 'type': 'PROFILE', 'timestamp': 1444077709}
Mon Oct 5 13:41:49 2015 **** CONNECT 52_10_154_117_dynamic_p4495 TRAY_CLIENT_ZGtsb3Bw_6rEWNYKw
Mon Oct 5 13:41:49 2015 Not tracking (already owned by us)
Mon Oct 5 13:41:49 2015 Connect, sid= sess_52_10_154_117_dynamic_p4495_XeXRCBzVAWeHKoKK_1
Mon Oct 5 13:41:49 2015 Tracking owned session
Mon Oct 5 13:41:49 2015 generating sub_poll parameters
Mon Oct 5 13:41:49 2015 track_profile_connect: done
Mon Oct 5 13:41:49 2015 '52_10_154_117_dynamic_p4495' -> {'status': 'need', 'timestamp': 1444077709, 'need': ['username', 'password'], 'type': 'PASSWORD', 'auth_type': 'Dynamic'}
Mon Oct 5 13:41:52 2015 authenticate: host=u'52.10.154.117' user=u'dklopp' response=None
Mon Oct 5 13:41:52 2015 authenticate: using preferred host: 52.10.154.117
Mon Oct 5 13:41:52 2015 authenticate: sid: 'sess_52_10_154_117_dynamic_p4495_XeXRCBzVAWeHKoKK_1' profile_id: '52_10_154_117_dynamic_p4495'
Mon Oct 5 13:41:52 2015 overriding host with preferred host: 52.10.154.117
Mon Oct 5 13:41:52 2015 -> SubmitCreds u'dklopp'
Mon Oct 5 13:41:52 2015 -> SubmitCreds returned: None
Mon Oct 5 13:41:53 2015 '52_10_154_117_dynamic_p4495' -> {'timestamp': 1444077713, 'info_type': 'DYNAMIC_SUCCEED', 'type': 'INFO', 'severity': 'info', 'value': 'dynamic profile access succeeded'}
Mon Oct 5 13:41:53 2015 other event: {'timestamp': 1444077713, 'info_type': 'DYNAMIC_SUCCEED', 'type': 'INFO', 'severity': 'info', 'value': 'dynamic profile access succeeded'}
Mon Oct 5 13:41:53 2015 '52_10_154_117_dynamic_p4495' -> {'timestamp': 1444077713, 'info_type': 'RUN_ERROR', 'type': 'INFO', 'severity': 'error', 'value': "JSONDialog: Error running jsondialog, status=(5, [], ['task_for_pid(): 0x5']), stdout=[], stderr=['task_for_pid(): 0x5']"}
Mon Oct 5 13:41:53 2015 got INFO event: {'timestamp': 1444077713, 'info_type': 'RUN_ERROR', 'type': 'INFO', 'severity': 'error', 'value': "JSONDialog: Error running jsondialog, status=(5, [], ['task_for_pid(): 0x5']), stdout=[], stderr=['task_for_pid(): 0x5']"}
Mon Oct 5 13:41:53 2015 >>>> {'timestamp': 1444077713, 'state': 'disconnect', 'profile_id': '52_10_154_117_dynamic_p4495', 'type': 'PROFILE'}
Mon Oct 5 13:41:53 2015 **** DISCONNECT 52_10_154_117_dynamic_p4495
Mon Oct 5 13:41:53 2015 '52_10_154_117_dynamic_p4495' -> {'timestamp': 1444077713, 'type': 'DELETE_PENDING'}
Mon Oct 5 13:41:53 2015 got DELETE_PENDING for: Profile[id=52_10_154_117_dynamic_p4495,owner=3,host=52.10.154.117,autologin=False,state=0] <function <lambda> at 0x935baf0>
Mon Oct 5 13:41:53 2015 notify_disconnect: 52.10.154.117 "JSONDialog: Error running jsondialog, status=(5, [], ['task_for_pid(): 0x5']), stdout=[], stderr=['task_for_pid(): 0x5']"

sbhornia
OpenVpn Newbie
Posts: 1
Joined: Thu Oct 08, 2015 2:49 am

Re: OpenVPN Connect Mac (10.11) Fails: Error running jsondia

Post by sbhornia » Thu Oct 08, 2015 2:51 am

I had same issue. I discovered that is because of SIP on El Capitan. You will need to disable, connect to vpn and re-enable if you want.

http://osxdaily.com/2015/10/05/disable- ... -mac-os-x/

stevefram
OpenVpn Newbie
Posts: 1
Joined: Sat Oct 10, 2015 12:21 am

Re: OpenVPN Connect Mac (10.11) Fails: Error running jsondia

Post by stevefram » Sat Oct 10, 2015 12:23 am

It would be great to fix this. The workaround worked, but I am thinking of licensing about 10 users and we don't want to disable rootless system integrity protection across the board.

pcarroll15
OpenVpn Newbie
Posts: 1
Joined: Thu Nov 19, 2015 6:46 pm

Re: OpenVPN Connect Mac (10.11) Fails: Error running jsondia

Post by pcarroll15 » Tue Dec 01, 2015 4:55 pm

Any updates here? I am seeing the same issue and we have many Mac's disabling this for several remote users is undesirable.

anonymoose
OpenVpn Newbie
Posts: 2
Joined: Mon Dec 14, 2015 8:28 am

Re: OpenVPN Connect Mac (10.11) Fails: Error running jsondia

Post by anonymoose » Mon Dec 14, 2015 8:34 am

My understanding is that this was fixed in v1.7.1 of open connect client.

That being said, my server is configured issue v1.7.0 of the open connect client.

Would anyone be able to guide me as to how I might update my server to issue v1.7.1 of the open connect client??

Looking forward to any thoughts.

User avatar
novaflash
OpenVPN Inc.
Posts: 1071
Joined: Fri Apr 13, 2012 8:43 pm

Re: OpenVPN Connect Mac (10.11) Fails: Error running jsondia

Post by novaflash » Sat Jan 09, 2016 5:44 pm

Just posting here to clarify something;

Macintosh OS X 10.11, aka El Capitan, caused a JSONdialog 5 error in OpenVPN Connect Clients that are older than version 2.0.18.203 for Mac. This is because of the system integrity feature that is implemented in El Capitan. Only a few days after El Capitan was released, we released Access Server 2.0.21 that contains the new 2.0.18.203 Connect Client that fixes this issue. If you are on an older version of Access Server, please upgrade. If you are on 2.0.21 of Access Server and still see this problem, kindly go to your Access Server and download and install the Connect Client for Mac again to upgrade it to 2.0.18.203 (or higher).

mcmatusz
OpenVpn Newbie
Posts: 1
Joined: Tue Jan 12, 2016 4:15 am

Re: OpenVPN Connect Mac (10.11) Fails: Error running jsondia

Post by mcmatusz » Tue Jan 12, 2016 4:17 am

I get this error as well. I just downloaded Access Server from AWS Marketplace, but the most recent version available is 2.0.20. Is there any other way to upgrade to 2.0.21?

Post Reply