Cannot Reach local network when connected to Openvpn

Post Reply
gran061
OpenVpn Newbie
Posts: 1
Joined: Thu Mar 26, 2020 8:25 am

Cannot Reach local network when connected to Openvpn

Post by gran061 » Thu Mar 26, 2020 8:46 am

Good day

With the whole pandemic around us, and lockdowns happening, we are implementing remote staff that need to connect to our local network from home. And what better way to do this via VPN. That being said, here are the details:

I have a physical Linux server that uses oracle VirtualBox. On it, I have our CentOS VM running Openvpnas. The VPN works great when connecting to it all clients connected to it have internet access, but just not accessible to the router local network.

My router has its own DHCP server on it that subnets its local network, which is 192.168.8.0. And my physical server has its local IP 192.168.8.69 and the CentOS VM, which is connected via a bridged adapter, promiscuous mode is set to "Allow All". Also has its own static IP 192.168.8.93. When I installed Openvpn (Which I am not 100% familiar with), it created its own private subnet network, which in this case is 172.27.240.0 and any client connected via OpenVPN is put on this new private network.

I can confirm that the VM has IP forwarding enabled, and at this time I have OpenVPN set to use NAT routing, and in the GUI settings, I added the subnet 192.168.8.0/24 to the "Specify the private subnets to which all clients should be given access" field. However, when I use a different ISP (Like 4G Mobile data) on my client and connect to the OpenVPN via the app. I get connected and everything works as expected. On this remote ISP network, my client private IP will be something like 192.168.178.20 for example.

But when I run a ping test from this client to let's say 192.168.8.1 or 192.168.8.69 it times out. The client can only ping its own local network, which in that case will be 192.168.178.0.

What am I missing here? is there something I am supposed to enable on top of this? Any assistance will be highly appreciated, please.

Post Reply