OVPN Connect from S10 - disconnects immed now!

Post Reply
info4tim
OpenVpn Newbie
Posts: 8
Joined: Mon Feb 26, 2018 1:07 pm

OVPN Connect from S10 - disconnects immed now!

Post by info4tim » Wed Feb 12, 2020 12:12 pm

Hey folks,
For months (up till ~3 months ago) I connected from my S10 via Verizon LTE to my OVPN server with no problems. Now, it Immediately disconnects and keeps trying to no avail. It says "Waiting For Server". Any ideas?

Here's my Connect log file:

10:18:58.563 -- ----- OpenVPN Start -----

10:18:58.563 -- EVENT: CORE_THREAD_ACTIVE

10:18:58.565 -- OpenVPN core 3.git::728733ae:Release android arm64 64-bit PT_PROXY built on Aug 14 2019 14:13:26

10:18:58.566 -- Frame=512/2048/512 mssfix-ctrl=1250

10:18:58.572 -- UNUSED OPTIONS
4 [resolv-retry] [infinite]
5 [nobind]
8 [verify-x509-name] [raspberrypi_42b13a16-860a-419b-a2b6-763b3e56c02b] [name]
11 [auth-nocache]
12 [verb] [3]

10:18:58.572 -- EVENT: RESOLVE

10:18:58.769 -- Contacting x.x.x.x:xxxx via UDP

10:18:58.770 -- EVENT: WAIT

10:18:58.773 -- Connecting to [myserver.ddns.net]:xxxx (x.x.x.x) via UDPv4

10:19:08.573 -- Server poll timeout, trying next remote entry...

10:19:08.601 -- EVENT: RECONNECTING

10:19:08.604 -- EVENT: RESOLVE

10:19:08.608 -- Contacting x.x.x.x:xxxx via UDP

10:19:08.608 -- EVENT: WAIT

10:19:08.613 -- Connecting to [myserver.ddns.net]:xxxx (x.x.x.x) via UDPv4

10:19:09.453 -- EVENT: DISCONNECTED

10:19:09.453 -- Tunnel bytes per CPU second: 0

10:19:09.453 -- ----- OpenVPN Stop -----

User avatar
Pippin
Forum Team
Posts: 605
Joined: Wed Jul 01, 2015 8:03 am

Re: OVPN Connect from S10 - disconnects immed now!

Post by Pippin » Wed Feb 12, 2020 3:47 pm

Code: Select all

10:19:08.573 -- Server poll timeout, trying next remote entry...
It means the server (the pi) cannot be reached.

Check port forwards and firewall.
Does it ever connect?

info4tim
OpenVpn Newbie
Posts: 8
Joined: Mon Feb 26, 2018 1:07 pm

Re: OVPN Connect from S10 - disconnects immed now!

Post by info4tim » Wed Feb 12, 2020 7:45 pm

Thx for reply. Not for last sev months. Keeps reconnecting/disconnecting. Did Nothing to any setting.

User avatar
Pippin
Forum Team
Posts: 605
Joined: Wed Jul 01, 2015 8:03 am

Re: OVPN Connect from S10 - disconnects immed now!

Post by Pippin » Wed Feb 12, 2020 7:51 pm

Does it work from another network, not LTE?
Or a different device?

info4tim
OpenVpn Newbie
Posts: 8
Joined: Mon Feb 26, 2018 1:07 pm

Re: OVPN Connect from S10 - disconnects immed now!

Post by info4tim » Wed Feb 12, 2020 9:00 pm

Negative. Should I see the attempt in the fios router log?

User avatar
Pippin
Forum Team
Posts: 605
Joined: Wed Jul 01, 2015 8:03 am

Re: OVPN Connect from S10 - disconnects immed now!

Post by Pippin » Wed Feb 12, 2020 9:10 pm

No, your rpi vpn log.

info4tim
OpenVpn Newbie
Posts: 8
Joined: Mon Feb 26, 2018 1:07 pm

Re: OVPN Connect from S10 - disconnects immed now!

Post by info4tim » Wed Feb 12, 2020 11:10 pm

Ok when get back home this eve. So wouldn't get any entries in router log then.

info4tim
OpenVpn Newbie
Posts: 8
Joined: Mon Feb 26, 2018 1:07 pm

Re: OVPN Connect from S10 - disconnects immed now!

Post by info4tim » Thu Feb 13, 2020 3:28 pm

On the pi, here's the /var/log/openvpn-status.log file contents:

TITLE OpenVPN 2.4.7 arm-unknown-linux-gnueabihf [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Feb 20 2019
TIME Thu Feb 13 10:21:03 2020 1581607263
HEADER CLIENT_LIST Common Name Real Address Virtual Address Virtual IPv6 Address Bytes Received Bytes Sent Connected Since Connected Since (time_t) Username Client ID Peer ID
HEADER ROUTING_TABLE Virtual Address Common Name Real Address Last Ref Last Ref (time_t)
GLOBAL_STATS Max bcast/mcast queue length 0
END

Are there other logs I should peruse? Also attempted to connect from another device on wifi on same network as pi - Droid tablet to no avail.

info4tim
OpenVpn Newbie
Posts: 8
Joined: Mon Feb 26, 2018 1:07 pm

Re: OVPN Connect from S10 - disconnects immed now!

Post by info4tim » Sat Feb 15, 2020 9:14 pm

As shown above, pi sees some type of comm, (file is touched at exactly my connect time attempt) but no info?
Anyone have an idea?
Thanks

Post Reply