vars file: EASYRSA_CERT_EXPIRE is not applied?

Support forum for Easy-RSA certificate management suite.

Moderators: TinCanTech, TinCanTech, TinCanTech, TinCanTech, TinCanTech, TinCanTech

Post Reply
vayer
OpenVpn Newbie
Posts: 2
Joined: Thu Aug 31, 2023 4:13 am

vars file: EASYRSA_CERT_EXPIRE is not applied?

Post by vayer » Thu Aug 31, 2023 4:30 am

Hello.
I want to create client certificate for 5 years.

I assigned the parameter in vars file: EASYRSA_CERT_EXPIRE 1825

But easyrsa3 generated client certificate for 2 years.

commands (Windows console):
=======================
./easyrsa --vars=vars1
./easyrsa gen-req test nopass
./easyrsa sign-req client test

User avatar
Pippin
Forum Team
Posts: 1200
Joined: Wed Jul 01, 2015 8:03 am
Location: irc://irc.libera.chat:6697/openvpn

Upgrade v2 to v3 - vars file: EASYRSA_CERT_EXPIRE is not applied? [Solved]

Post by Pippin » Mon Sep 04, 2023 6:10 pm

Hi,

It looks like you are upgrading from EasyRSA version 2, the command you need for EasyRSA version 3 is:

Code: Select all

./easyrsa --vars=vars1 build-client-full test nopass
.
I gloomily came to the ironic conclusion that if you take a highly intelligent person and give them the best possible, elite education, then you will most likely wind up with an academic who is completely impervious to reality.
Halton Arp

vayer
OpenVpn Newbie
Posts: 2
Joined: Thu Aug 31, 2023 4:13 am

Re: vars file: EASYRSA_CERT_EXPIRE is not applied?

Post by vayer » Wed Sep 20, 2023 6:12 am

I confirm. This - "./easyrsa --vars=vars1 build-client-full test nopass" - work correctly.
Thank you for help.

Post Reply