Page 1 of 1

openVPN only works after reinstall

Posted: Wed Mar 29, 2023 9:08 am
by kiona

When I start up my mac and want to open openVPN i'm Getting a connection timeout with a "Error calling protect() method on socket: 30 times"
When I reinstall the openVPN, then it works great, no time out. I can quit and open again, no problem. But as soon as I shut down my mac and start up, the openVPN app will not run anymore, I need toe reinstall it.

I also tried to completely uninstall openVPN and install again. Same problem as above. I used other versions, did not work, keep having the problem.
I work with OSX 13.2.1
Installed version of openVPN connect
Tried version:
and version:

Does anyone know what the problem is?

thanks already

Re: openVPN only works after reinstall

Posted: Tue Apr 18, 2023 7:53 am
by JosephS
Sounds like the openVPN connect launch daemon is not working.
Can you run the following command in the terminal and see if you get an output:

Code: Select all

sudo launchctl list | grep org.openvpn.client
If there are no outputs then you can try loading it manually via the command:

Code: Select all

sudo launchctl load /Library/LaunchDaemons/org.openvpn.client.plist
But, in case if it will stop working again you may want to check if there is any other 3rd party application that is preventing the ovpn client agent from starting.

Re: openVPN only works after reinstall

Posted: Sun Aug 27, 2023 5:34 am
by retry
Thank you for the solution. It works!

I've been facing this for 3-6 months, constantly reinstalling the OpenVPN client on Mac(macbook m1, Ventura 13.4). I couldn't find this solution when I was looking for this exact bug in GitHub issues. Apparently, no one had created it.

I personally didn't understand what exactly breaks the client. Do you have any suggestions on what I should investigate?