Page 1 of 1

Cannot start OpenVPN Access Server after installing

Posted: Wed Feb 01, 2023 4:49 pm
by kokozin
Hi,
I've installed AS on my Ubuntu 20.04 LTS and the AS cannot be started after installing.

Here's what I get from `systemctl status`:

Code: Select all

‚óŹ openvpnas.service - OpenVPN Access Server
     Loaded: loaded (/lib/systemd/system/openvpnas.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Wed 2023-02-01 22:39:52 +0630; 30min ago
    Process: 27949 ExecStart=/usr/local/openvpn_as/scripts/openvpnas --nodaemon --logfile=/var/log/openvpnas.log --pidfile= (code=exited, status=1/FAILURE)
   Main PID: 27949 (code=exited, status=1/FAILURE)

Feb 01 22:39:52 koko-Inspiron-3250 systemd[1]: Started OpenVPN Access Server.
Feb 01 22:39:52 koko-Inspiron-3250 openvpnas[27949]: Traceback (most recent call last):
Feb 01 22:39:52 koko-Inspiron-3250 openvpnas[27949]:   File "<string>", line 1, in <module>
Feb 01 22:39:52 koko-Inspiron-3250 openvpnas[27949]: zipimport.ZipImportError: can't find module 'pyovpn'
Feb 01 22:39:52 koko-Inspiron-3250 systemd[1]: openvpnas.service: Main process exited, code=exited, status=1/FAILURE
Feb 01 22:39:52 koko-Inspiron-3250 systemd[1]: openvpnas.service: Failed with result 'exit-code'.
Here's the system info:

Code: Select all

No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 20.04.5 LTS
Release:	20.04
Codename:	focal
Here's the CPU architecture:

Code: Select all

Architecture:                    x86_64
CPU op-mode(s):                  32-bit, 64-bit
Byte Order:                      Little Endian
Address sizes:                   39 bits physical, 48 bits virtual
CPU(s):                          4
On-line CPU(s) list:             0-3
Thread(s) per core:              1
Core(s) per socket:              4
Socket(s):                       1
NUMA node(s):                    1
Vendor ID:                       GenuineIntel
CPU family:                      6
Model:                           94
Model name:                      Intel(R) Core(TM) i5-6400 CPU @ 2.70GHz
Stepping:                        3
CPU MHz:                         800.027
CPU max MHz:                     3300.0000
CPU min MHz:                     800.0000
BogoMIPS:                        5399.81
Virtualization:                  VT-x
L1d cache:                       128 KiB
L1i cache:                       128 KiB
L2 cache:                        1 MiB
L3 cache:                        6 MiB
NUMA node0 CPU(s):               0-3
Vulnerability Itlb multihit:     KVM: Mitigation: Split huge pages
Vulnerability L1tf:              Mitigation; PTE Inversion; VMX conditional cache flushes, SMT disabled
Vulnerability Mds:               Mitigation; Clear CPU buffers; SMT disabled
Vulnerability Meltdown:          Mitigation; PTI
Vulnerability Mmio stale data:   Mitigation; Clear CPU buffers; SMT disabled
Vulnerability Retbleed:          Mitigation; IBRS
Vulnerability Spec store bypass: Mitigation; Speculative Store Bypass disabled via prctl and seccomp
Vulnerability Spectre v1:        Mitigation; usercopy/swapgs barriers and __user pointer sanitization
Vulnerability Spectre v2:        Mitigation; IBRS, IBPB conditional, RSB filling, PBRSB-eIBRS Not affected
Vulnerability Srbds:             Mitigation; Microcode
Vulnerability Tsx async abort:   Not affected
Flags:                           fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc a
                                 rt arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid ss
                                 e4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch cpuid_fault epb invpcid_single pti ssbd ibrs ibpb stibp tpr_
                                 shadow vnmi flexpriority ept vpid ept_ad fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid mpx rdseed adx smap clflushopt intel_pt xsaveopt xsavec xgetbv1 xsave
                                 s dtherm ida arat pln pts hwp hwp_notify hwp_act_window hwp_epp md_clear flush_l1d arch_capabilities
I installed the package Ubuntu 20, x86_64 via repository as instructed in installation guide.

Best regards.

Re: Cannot start OpenVPN Access Server after installing

Posted: Wed Feb 01, 2023 9:58 pm
by openvpn_inc
Hello kokozin,

Pretty sure it works just fine on Ubuntu 20 x64, we test thoroughly before every release and Ubuntu 20 x64 is on the list of tested platforms. However, there may be something particular to your system that's causing something to fail. Is this a system on some cloud provider that we can test on ourselves? Or is this just an install on your own system? Is it running under some virtualization system? Is this a fresh install or something that's been around and possibly modified in subtle ways? Is this installed with or without recommended packages or not? Does it have a custom kernel?

Kind regards,
Johan