Page 2 of 2

Re: No internet connection after disconnecting from OpenVPN server

Posted: Sat Nov 18, 2023 1:19 pm
by IndyCarSuperFan
This is clearly an issue that is yet t be resolved with OpenVPN and macOS. This has been ongoing for years with macOS and OpenVPN regarding of Intel or Apple silicon.

The only solution I've had success with, albeit annoying and should NOT need to be done, is disabling and reenabling the Wi-Fi connection. I have not tried this with a wired connection so I can't speak to what happens in that scenario.

Regardless, the OpenVPN developers have zero interest in fixing this issue with macOS. However, it's a free application, so how much can we really complain?

Re: No internet connection after disconnecting from OpenVPN server

Posted: Mon Dec 25, 2023 1:19 pm
by lonetree
@IndyCarSuperFan

I can tell you that wired connection suffers the same fate too.

Would you be kind to share what you are using as your openvpn router?

Thanks

Re: No internet connection after disconnecting from OpenVPN server

Posted: Tue Dec 26, 2023 5:39 pm
by rchiker5
I have this same issue and it's really annoying.

I find the easiest way to address this is reboot my Mac but that is equally annoying. This doesn't happen on my Windows laptop or my iPhone at least which is nice.

I am running Sonoma 14.2.1 and have OpenVPN setup on my Asus RT-AX82U running firmware 3.0.0.4.388_24231-gbc11d13

My setup is

TUN
UDP
AES-256-GCM
SHA 512
Compression - Disabled
TLS
HMAC Auth - Disabled
VPN Subnet 10.8.0.0 (Wifi network is 192.168.50.x)
Push LAN to clients - Enabled
Direct clients to redirect internet traffic - Enabled


Previously I had OpenVPN loaded on my Synology NAS and I never recall having this issue. I may go back to that setup and see if works better. I was just having problems enabling cert auth in that setup. That setup was easier in the Asus router so I switched to this setup.