Page 1 of 1

OPENVPN Connect Mac Safari not working

Posted: Wed Sep 21, 2022 4:58 pm
by toggee
Hi,

I have configured my Synology NAS and can connect via the OpenVPN Connect app from my Macbook Pro and chrome works fine but Safari wont load any pages?

Any ideas?

Andrew

Re: OPENVPN Connect Mac Safari not working

Posted: Wed Sep 21, 2022 5:09 pm
by openvpn_inc
Hello toggee/Andrew,

Pretty hard to say without any further details. I'm guessing it's the simple case of a DNS server being pushed that just doesn't work right, and Chrome might be able to work around that while Safari can't. Really hard to say without any further details. You could check the client side log to see if a DNS server is being pushed. You could check Synology configuration if pushing a DNS server can be switched off or if you can push a custom DNS server that works properly in the circumstances that matter.

Kind regards,
Johan

Re: OPENVPN Connect Mac Safari not working

Posted: Thu Dec 01, 2022 2:22 pm
by TomasHamal
Hello,

we're having the similar problem with safari, we are running OpenVPN on an Ubuntu server, and the problems does not look to me as relevant to DNS. Other browser work as expected. So I am trying to debug this issue.

Till now I found, that something blocks the request from processing and I am searching for some relevant information using wireshark:
Image

There are now entries in OpenVPN log, on server or client.

I doubt it is a OpenVPN problem, rather in Safari, but we need to find a cause and report it to the corresponding party