Page 1 of 1

Unable to connect (toggle switch doesn't work)

Posted: Thu Aug 04, 2022 9:59 pm
by CaptainFedora
I set up an OpenVPN server on my RaspberryPi and everything was working perfectly until I factory reset the phone (and did a root). I also have the Blokada5 app installed which blocks access to ads. However, both of these VPN apps worked fine together before. After resetting the device, it cannot connect via OpenVPN to my server. I have no idea where the issue might be. There is no log available either. Doesn't Android have some built-in logging mechanism where I can find out the cause of this problem?

Here's the issue captured with screen record

Android 12 (rooted + Magisk)
OnePlus 8T (stock OxygenOS - no beta)

If root may be the cause, then why Blokada5 does work? I tried reinstall OpenVPN app so many times and no luck there. I also can connect to my server through Windows OpenVPN app, so the .ovpn profile is set up good.

Re: Unable to connect (toggle switch doesn't work)

Posted: Mon Aug 08, 2022 11:39 am
by CaptainFedora
Problem solved. Here's the solution: ... t.4477123/