Page 1 of 1

certificate verify failed

Posted: Wed Jun 29, 2022 4:47 am
by losuper
Hi to all,

I have what appears to be a CERTIFICATE related problem with OpenVPN configuration with my synology NAS Server.

The problem I have is this:
opensslcontext::ssl::read_cleartext:bio_read failed, cap=2576 status=-1: error:1416fo86:ssl routines:tls_process_server_certificate:certificate verify failed

I followed this tutorial to set up the server:[/url]

As in result I have:
  • Installed succesfully the server
  • Opened and tested the router ports (3323 also tested with default port)
  • Exported the OpenVPN conf file and changed YOUR_SERVER_IP with my ddns name and all my certificates are valid and in use
  • Turned OFF the server firewall to test purposes only
  • Installed the client both on windows and android
I've search all the forum entries and I think I've tried everything, even using other phones (allways out of my network ofcourse), creating new users, start from scratch several times, and I don't know what to do more, it appears to be all OK but keeps failing.

Any help please?

Re: certificate verify failed

Posted: Thu Jul 07, 2022 1:26 pm
by gvr_
I have exact the same issue. My ovpn server on synology is working well, I can connect to it from my windows laptop, but from my android device I get the error 'certificate verify failed'. I use the same config file on android and windows.

On my synology I use the default synology certificate for the vpn server and I use SHA256 for encryption. I use my ddns adress to connect. I also tested with a let's encrypt certificate and my domain adress, but same issue. The fact that I can succesfully connect on my windows laptop tells me that the're nothing wrong with my server config (file), but I don't understand why I get this error on Android.

Re: certificate verify failed

Posted: Fri Jul 08, 2022 5:59 am
by gvr_
My problem is solved by using the "OpenVPN for Android" app instead of the "official" openvpn app. So, there's a bug in the offical app.
@losuper maybe using the other client app can solve your problem too?

Re: certificate verify failed

Posted: Tue Sep 27, 2022 5:21 am
by Jameswalter
This can occur for example if you are using an MD5 signed certificate. With such a type of certificate, the security level is so low, that the authenticity of the certificate simply cannot by any reasonable means be assured.