Connected but no traffic

Official client software for OpenVPN Access Server and OpenVPN Cloud.
Post Reply
Meserias
OpenVpn Newbie
Posts: 18
Joined: Sun Oct 17, 2021 3:01 pm

Connected but no traffic

Post by Meserias » Wed Nov 17, 2021 11:28 am

I have installed OpenVPN Connect version 3.2.5 in my phone.
Imported all necesary things and saved a profile.

I can successfully connect, but I have no traffic along this VPN tunnel.
What I'm doing wrong ? Why OpenVPN route it's not added to my android 10 phone after connection.

Server it's having this IP 10.8.0.1....I should be able to PING the server at least.

IMPORTANT NOTE: please keep in mind that connecting from a remote Windows machine to this server WORKS and traffic it's routed trough OpenVPN

Meserias
OpenVpn Newbie
Posts: 18
Joined: Sun Oct 17, 2021 3:01 pm

Re: Connected but no traffic

Post by Meserias » Sat Dec 04, 2021 2:10 pm

I'm coming back to this thread....the problem was a setting that was enabled in the server but not in client-side ovpn file.
In order to solve it, I added this to client config:

I added:

Code: Select all

compress

TinCanTech
OpenVPN Protagonist
Posts: 11135
Joined: Fri Jun 03, 2016 1:17 pm

Re: Connected but no traffic

Post by TinCanTech » Sat Dec 04, 2021 2:21 pm

And now you have a less secure VPN.

Remove all compression setting from both server and client.

Meserias
OpenVpn Newbie
Posts: 18
Joined: Sun Oct 17, 2021 3:01 pm

Re: Connected but no traffic

Post by Meserias » Sat Dec 04, 2021 4:01 pm

Removed, as suggested.
Everything works.
Thank you

brianm
OpenVpn Newbie
Posts: 1
Joined: Thu Sep 21, 2023 4:22 pm

Re: Connected but no traffic

Post by brianm » Thu Sep 21, 2023 4:25 pm

Oh thank you thank you thank you! I've been battling this issue off and on for months. I've been on a wild goose chase going after network routing issues, because it couldn't find any of my subnets. There should really be an error message or better recovery if the server and client compressions don't match. Just having it connect, but have nothing work, makes it really tough to hunt this down. Thank you for posting this. I would have never guess compression was the issue.

Post Reply