Errors running client.ovpn

Official client software for OpenVPN Access Server and OpenVPN Cloud.
Post Reply
User avatar
BigRich
OpenVpn Newbie
Posts: 3
Joined: Sat Sep 25, 2021 3:44 pm

Errors running client.ovpn

Post by BigRich » Sun Sep 26, 2021 4:48 pm

I am a newbie to VPN but not a novice when it comes to computers and networks. Pretty rusty though.

I enabled Dynamic DNS (as recommended by Netgear) and VPN service on my Netgear RAX80 router. I then downloaded Netgear's client.ovpn and config files .

I then installed OpenVPN and renamed the "TAP-Windows Adapter V9" to "NETGEAR-VPN" as recommended by Netgear.

I then right clicked on the OpenVPN configuration file and selected Start OpenVPN on this configuration file, as recommended on this site.

The command window opened and I let it run for about 10 minutes but it seemed to be in a cycle of repeating errors. Two that I noted were it complaining the "Key negotiations failed to occur within 60 seconds". And another line which complained "No Server Certificate Verification method".

In my case I assume the VPN Server is reached through my router but that may not be happening? I don't know.
Last edited by BigRich on Sun Sep 26, 2021 6:39 pm, edited 1 time in total.

User avatar
BigRich
OpenVpn Newbie
Posts: 3
Joined: Sat Sep 25, 2021 3:44 pm

Re: Errors running client.ovpn

Post by BigRich » Sun Sep 26, 2021 6:38 pm

I may have found a partial answer to my own question. I brought up a 'right-click' listing of antivirus commands (I'm running Avira). In the list it said "Turn on VPN". I clicked on that and the client.ovpn file ran afterwards.

Curious to me. client.ovpn finished, or it said "success" but continued the print rwrwrwrwrwrwrwrw, seemingly forever. I shut the command window down and it didn't seem to matter, the VPN was running. At least when I went to view my IP it was unrecognizable to anything associated with my ISP.

Now I have a new problem. It seems that I need to tell Avira to turn on the VPN each time I reboot.

Maybe it's time to get rid of Avira and find a way to automate the OpenVPN startup if that's possible.

And now the client.ovpn file complains that I don't have a IPv4 address assigned to the VPN adapter (NETGEAR-VPN). Should I just make one up and make it static?

User avatar
TinCanTech
Forum Team
Posts: 9951
Joined: Fri Jun 03, 2016 1:17 pm

Re: Errors running client.ovpn

Post by TinCanTech » Sun Sep 26, 2021 11:01 pm

BigRich wrote:
Sun Sep 26, 2021 4:48 pm
The command window opened and I let it run for about 10 minutes but it seemed to be in a cycle of repeating errors. Two that I noted were it complaining the "Key negotiations failed to occur within 60 seconds".
oh no ..
BigRich wrote:
Sun Sep 26, 2021 4:48 pm
And another line which complained "No Server Certificate Verification method".
oh well ..

There is a howto:
https://community.openvpn.net/openvpn/w ... troduction

User avatar
BigRich
OpenVpn Newbie
Posts: 3
Joined: Sat Sep 25, 2021 3:44 pm

Re: Errors running client.ovpn

Post by BigRich » Tue Sep 28, 2021 12:12 pm

TinCanTech wrote:
Sun Sep 26, 2021 11:01 pm
oh well ..

There is a howto:
https://community.openvpn.net/openvpn/w ... troduction
--------------------------------------------------------
Thanks a heap TinCanTech

Post Reply