Open VPN server does not detect intended disconnect

This is where we can discuss what we would like to see added or changed in OpenVPN.
Post Reply
ChiefRA
OpenVpn Newbie
Posts: 2
Joined: Fri Jun 14, 2019 11:22 am

Open VPN server does not detect intended disconnect

Post by ChiefRA » Fri Jun 14, 2019 11:30 am

Hello all,

I have installed OpenVPN Community Edition server on a Debian system (Raspberry PI) it's up-to-date, latest version and everything works smoothly and correct.

The only thing I've noticed is that when I disconnect from Desktop/Laptop OpenVPN client, the server doesn't detect the intended disconnection thus keeps the connection active for another 5 mins when it goes into timeout.

This is happening only on Laptop clients (tested on both Windows and MacOS same behavior). On mobile clients, tested on both iOS and Android, when I disconnect the server correctly closes the connection thus acknowledges the intended disconnect.

Can you please fix this small issue?

If you need further details please let me know and I will provide what you need.

Thank you.
ChiefRA
Last edited by ChiefRA on Fri Jun 14, 2019 5:27 pm, edited 1 time in total.

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 5728
Joined: Fri Jun 03, 2016 1:17 pm

Re: Open VPN server does not detect intended disconnect

Post by TinCanTech » Fri Jun 14, 2019 1:15 pm

ChiefRA wrote:
Fri Jun 14, 2019 11:30 am
Can you please fix this small issue?
What issue ?
ChiefRA wrote:
Fri Jun 14, 2019 11:30 am
If you need further details please let me know and I will provide what you need.
Please see:
viewtopic.php?f=30&t=22603

ChiefRA
OpenVpn Newbie
Posts: 2
Joined: Fri Jun 14, 2019 11:22 am

Re: Open VPN server does not detect intended disconnect

Post by ChiefRA » Fri Jun 14, 2019 5:28 pm

ChiefRA wrote:
Fri Jun 14, 2019 11:30 am
when I disconnect from Desktop/Laptop OpenVPN client, the server doesn't detect the intended disconnection thus keeps the connection active for another 5 mins when it goes into timeout.
This issue :)

I read your link, I prepare the data and I'll upload it asap.
Thank you for the link.

Post Reply