[Windwos] VPN Connecting but no internet/ping

Need help configuring your VPN? Just post here and you'll get that help.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
veticatech
OpenVpn Newbie
Posts: 1
Joined: Thu Feb 14, 2019 6:46 am

[Windwos] VPN Connecting but no internet/ping

Post by veticatech » Thu Feb 14, 2019 6:52 am

Server is running on a Windows 10 machine (192.168.1.10)
Client connecting is Windows 10 (192.168.2.X)

Client gets ip 192.168.1.30 and connects but cannot browse or ping
Firewall is off, no AV

server.ovpn:

Code: Select all

port 1194
proto udp
dev tun
ca "C:\\Program Files\\OpenVPN\\config\\ca.crt"
cert "C:\\Program Files\\OpenVPN\\config\\server.crt"
key "C:\\Program Files\\OpenVPN\\config\\server.key"
dh "C:\\Program Files\\OpenVPN\\config\\dh1024.pem"
tls-auth "C:\\Program Files\\OpenVPN\\config\\ta.key" 0
server 192.168.1.0 255.255.255.0
ifconfig-pool-persist ipp.txt
push "redirect-gateway def1 bypass-dhcp"
push "dhcp-option DNS 192.168.1.5"
push "dhcp-option DNS 1.1.1.1"
keepalive 10 120
cipher AES-256-CBC
comp-lzo
persist-key
persist-tun
status openvpn-status.log
verb 3
explicit-exit-notify 1
client.ovpn:

Code: Select all

client
dev tun
proto udp
remote mail.domain.com 1194
resolv-retry infinite
nobind
comp-lzo
persist-key
persist-tun
remote-cert-tls server
key-direction 1
cipher AES-256-CBC
verb 3
<ca>
-----BEGIN CERTIFICATE-----
removed for safety
-----END CERTIFICATE-----
</ca>
<cert>
-----BEGIN CERTIFICATE-----
removed for safety
-----END CERTIFICATE-----
</cert>
<key>
-----BEGIN PRIVATE KEY-----
removed for safety
-----END PRIVATE KEY-----
</key>
<tls-auth>
-----BEGIN OpenVPN Static key V1-----
removed for safety
-----END OpenVPN Static key V1-----
</tls-auth>
For reference I was going off this guide:
https://www.reddit.com/r/OpenVPN/comments/81q2q6/guide_how_to_set_up_openvpn_server_on_windows_10/

Post Reply