Can downgrade openvpn version to 2.3 in Ubuntu 18.04 LTS?

This forum is for admins who are looking to build or expand their OpenVPN setup.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
crainar
OpenVpn Newbie
Posts: 5
Joined: Tue Feb 12, 2019 5:53 pm

Can downgrade openvpn version to 2.3 in Ubuntu 18.04 LTS?

Post by crainar » Tue Feb 12, 2019 5:55 pm

I need to install version opencpn 2.3.xx on a Linux Ubuntu 18.04 LTS.

Is this possible?

How can you do it?

Thanks to everyone in advance.

This is for new Ubuntu 18.04 LTS client with openvpn 2.4.4

My server is Ubuntu 16.04 LTS with openvpn 2.3.10

At this moment when I try to connect in new client with Ubuntu 18 openvpn log error:

Error: any valid prefix is expected rather than "10.8.110.21/-1".
Tue Feb 12 18:11:57 2019 us=155560 Linux ip addr add failed: external program exited with error status: 1
Tue Feb 12 18:11:57 2019 us=155759 Exiting due to fatal error

I try : sudo apt-get install openvpn=2.3.10 but doesn't workn error: can't find in repository version «2.3.10»

If I put openvpn 2.3 with Ubuntu 16 its work, but I need Ubuntu 18.04 in new client.

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 5578
Joined: Fri Jun 03, 2016 1:17 pm

Re: Can downgrade openvpn version to 2.3 in Ubuntu 18.04 LTS?

Post by TinCanTech » Tue Feb 12, 2019 6:10 pm

crainar wrote:
Tue Feb 12, 2019 5:55 pm
Error: any valid prefix is expected rather than "10.8.110.21/-1".
The error has nothing to do with your version of openvpn.

Please correct the error in your config file.

crainar
OpenVpn Newbie
Posts: 5
Joined: Tue Feb 12, 2019 5:53 pm

Re: Can downgrade openvpn version to 2.3 in Ubuntu 18.04 LTS?

Post by crainar » Tue Feb 12, 2019 7:40 pm

But my client (2.4.4 version) config file only have:


client
dev tap
;dev tun
;dev-node MyTap
;proto tcp
proto udp
remote 185.166.214.136 1194
resolv-retry infinite
nobind
persist-key
persist-tun
ca /home/MaskedSoftware/VPNs/SEMMINER1/ca.crt
cert /home/MaskedSoftware/VPNs/SEMMINER1/nodeAPI2.crt
key /home/MaskedSoftware/VPNs/SEMMINER1/nodeAPI2.key
tls-auth /home/MaskedSoftware/VPNs/SEMMINER1/ta.key 1
cipher AES-256-CBC
compress
Last edited by crainar on Tue Feb 12, 2019 7:48 pm, edited 1 time in total.

crainar
OpenVpn Newbie
Posts: 5
Joined: Tue Feb 12, 2019 5:53 pm

Re: Can downgrade openvpn version to 2.3 in Ubuntu 18.04 LTS?

Post by crainar » Tue Feb 12, 2019 7:44 pm

Server (2.3.10 version) config only have it:

;local a.b.c.d
port 1194
;proto tcp
proto udp
dev tap
;dev tun
;dev-node MyTap
ca /etc/openvpn/ca.crt
cert /etc/openvpn/server.crt
key /etc/openvpn/server.key # This file should be kept secret
dh /etc/openvpn/dh2048.pem
;topology subnet
;server 10.8.0.0 255.255.255.0
ifconfig-pool-persist /etc/openvpn/ipp.txt
server-bridge 10.8.110.4 255.255.254.0 10.8.110.50 10.8.111.250
;server-bridge
;push "route 192.168.10.0 255.255.255.0"
;push "route 192.168.20.0 255.255.255.0"
client-config-dir /etc/openvpn/staticclients
;route 192.168.40.128 255.255.255.248
;client-config-dir ccd
;route 10.9.0.0 255.255.255.252
;learn-address ./script
;push "redirect-gateway def1 bypass-dhcp"
;push "dhcp-option DNS 208.67.220.220"
client-to-client
duplicate-cn
keepalive 10 120
tls-auth /etc/openvpn/ta.key 0 # This file is secret
;cipher BF-CBC # Blowfish (default)
;cipher AES-128-CBC # AES
cipher AES-256-CBC
;cipher DES-EDE3-CBC # Triple-DES
;auth SHA256
comp-lzo
;max-clients 100
user nobody
group nogroup
persist-key
persist-tun
status openvpn-status.log
log openvpn.log
log-append openvpn.log
verb 6
;mute 20

crainar
OpenVpn Newbie
Posts: 5
Joined: Tue Feb 12, 2019 5:53 pm

Re: Can downgrade openvpn version to 2.3 in Ubuntu 18.04 LTS?

Post by crainar » Tue Feb 12, 2019 7:52 pm

TinCanTech wrote:
Tue Feb 12, 2019 6:10 pm
crainar wrote:
Tue Feb 12, 2019 5:55 pm
Error: any valid prefix is expected rather than "10.8.110.21/-1".
The error has nothing to do with your version of openvpn.

Please correct the error in your config file.
May be a problem in static client file on server at line?
ifconfig-push 10.8.110.21 10.8.110.0

(in client 2.3.10 work but in 2.4.4 it work?

crainar
OpenVpn Newbie
Posts: 5
Joined: Tue Feb 12, 2019 5:53 pm

Re: Can downgrade openvpn version to 2.3 in Ubuntu 18.04 LTS?

Post by crainar » Wed Feb 13, 2019 8:10 am

TinCanTech wrote:
Tue Feb 12, 2019 6:10 pm
crainar wrote:
Tue Feb 12, 2019 5:55 pm
Error: any valid prefix is expected rather than "10.8.110.21/-1".
The error has nothing to do with your version of openvpn.

Please correct the error in your config file.
Thanks, I solve the problem, was in client config dir file, I assign this line :

ifconfig-push 10.8.110.21 10.8.110.0 [BAD]

ifconfig-push 10.8.110.21 255.255.255.0 [GOOD]

Thanks TinCanTech
Regards

Post Reply