TAP driver installation failed

This forum is for all inquiries relating to the installation of OpenVPN from source and with binaries.
Forum rules
Please visit (and READ) the OpenVPN HowTo http://openvpn.net/howto prior to asking any questions in here!
Post Reply
adamjen
OpenVpn Newbie
Posts: 1
Joined: Fri Jun 08, 2018 4:55 pm

TAP driver installation failed

Post by adamjen » Fri Jun 08, 2018 5:13 pm

PIA,
I have Windows 7 pro 64 bit and the Private Internet Access VPN client installed on my home PC. I have been using the VPN client for over a year without any problems. However, about a week ago the PIA VPN client started randomly disconnecting a few minutes after connecting to any server. Shortly after this issue began I started receiving a message that there was a new version of the VPN client (v80) available, previously I was using v65.

I uninstalled v65 and installed v80. When trying to connect to a VPN server I received the dreaded error message about the TAP driver needing to be reinstalled. However, the reinstall keeps failing.

I uninstalled PIA v80, made sure the driver and driver store was clear then did some research on the forums were I learned some people solved this problem by installing TAP windows before PIA. I tried installing several versions of TAP windows (the latest being tap-windows-9.21.2), however I keep getting a failure when trying to install the TAP driver.

I also tried installing several versions of openVPN including:
openvpn-install-2.4.6-I602
openvpn-install-2.3.18-I602-x86_64
openvpn-install-2.3.14-I002-x86_64
openvpn-install-2.3.14-I002-i686
openvpn-install-2.3.10-I001-x86_64
openvpn-install-2.3.10-I001-i686

However, all of these versions always fail to install the TAP driver.

I have tried the following;
Running the installer in admin mode, launching the installer from a command prompt running in admin mode.
Installing 64 bit/32 bit versions of openVPN (not at the same time of course).
Changing the windows compatibility of TAP installer to win7 (was set to vista?).
Manually installing the TAP driver through the windows hardware installation wizard.
Running the TAP windows installer in safe mode.
Disabling (temporarily) driver signature enforcement.
Disabling my firewall (comodo) and anti-virus (Avast) (note: even though I disabled these during installation they still generated logs so I'm not sure they were really disabled.)
Re-installing PIA v65.
None of these however have solved the problem.

The TAP driver files appear to be getting copied to the system 32 and driver store folders, but windows is not "registering" the driver properly. I have spent many hours on this now with no progress being made. Any help would be greatly appreciated. I will also try posting on the PIA forums.

Thank you.

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 4896
Joined: Fri Jun 03, 2016 1:17 pm

Re: TAP driver installation failed

Post by TinCanTech » Sat Jun 09, 2018 4:05 pm

OpenVPN are currently in the process of getting the TAP adapter Microsoft certified, this is due very soon.

I will try to update this thread when it becomes available and you can help test it for us 8-)

Post Reply