No Access to Subnet and Internet (server side) after Windows 10 Update, version 1803

This forum is for admins who are looking to build or expand their OpenVPN setup.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
VPNntunnl123
OpenVpn Newbie
Posts: 2
Joined: Fri Jun 08, 2018 6:29 am

No Access to Subnet and Internet (server side) after Windows 10 Update, version 1803

Post by VPNntunnl123 » Fri Jun 08, 2018 7:19 am

Hi,

my Problem is that after installing Windows 10 Update, Version 1803 I can't ping any PC on my server-side local Network with my client. The VPN Tunnel is still working because I can ping my VPN Server with the LAN IP Address and with the VPN IP Address. My Client (Raspberry Pi) is not on the local Network of my Server and he is not on the very common IP subnet 192.168.2.0.

LAN IP (server side): 192.168.2.0 Gateway 192.168.2.1 Server 192.168.2.196
VPN IP: 10.8.99.0

My Windows 10 Settings are:

Start -> Right-click My Computer -> Manage
Services
Right-click Routing and Remote Access -> Properties -> Automatic
Right-click Routing and Remote Access -> Start

Next:

Control Panel
Network and Sharing Center
Local Area Connection
Properties
Sharing
Tick the box "Allow other network users to connect through this computer's Internet connection"

regedit

Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
Value: IPEnableRouter
Type: REG_DWORD
Data: 0x00000001 (1)

I tried adding some static routes and I disabled the Servers Firewall completely but it hasn't worked out.

Here are the configs how it worked before the update. I had Internet Connection an I could ping every PC on LAN.

Server Config:

Code: Select all

dev tun
proto udp
port 1196
ca ca.crt
cert server.crt
key server.key
dh dh2048.pem
server 10.8.99.0 255.255.255.0
push "redirect-gateway def1 bypass-dhcp"
#push "redirect-gateway autolocal def1"
#push "dhcp-option DNS 217.237.150.188"
#push "dhcp-option DNS 8.8.8.8"
push "dhcp-option DNS 192.168.2.1"
push "route-gateway 192.168.2.1 255.255.255.0"
push "route 192.168.2.0 255.255.255.0"
#ifconfig-pool-persist ipp.txt
keepalive 10 120
comp-lzo
persist-key
persist-tun
#status openvpn-status.log
client-to-client
verb 4
#block-outside-dns
Client Config:

Code: Select all

dev tun
client
proto udp
remote <dyn DNS IP> 1196
resolv-retry infinite
nobind
persist-key
persist-tun
ca /etc/openvpn/client/ca.crt
cert /etc/openvpn/client/client1.crt
key /etc/openvpn/client/client1.key
comp-lzo
verb 4

Thank you for your help!

bbuckm
OpenVPN User
Posts: 37
Joined: Thu Apr 26, 2018 2:45 pm

Re: No Access to Subnet and Internet (server side) after Windows 10 Update, version 1803

Post by bbuckm » Sat Jun 09, 2018 3:29 pm

As mentioned on the other thread, I did a complete blog post on the subject of Windows 10 and OpenVPN. Is any of it any help?

VPNntunnl123
OpenVpn Newbie
Posts: 2
Joined: Fri Jun 08, 2018 6:29 am

Re: No Access to Subnet and Internet (server side) after Windows 10 Update, version 1803

Post by VPNntunnl123 » Thu Jun 14, 2018 2:21 pm

Thank you for your answer. Unfortunately nothing worked. But I have used Wireshark to figure out why I can't ping any PC on LAN. When I ping these PCs I can see with Wireshark that the data packet gets to the Destination (LAN PC) but the Source IP Addresse is 10.8.99.6 (client). Could it be that the PC doesn't know this IP and because of this can't answer? I think it has something to do with the static routes of my server. I tried these routes:

route ADD -p 192.168.2.0 MASK 255.255.255.0 10.8.99.1
route ADD -p 10.8.99.0 MASK 255.255.255.0 192.168.2.196

It doesn't work. Can somebody help?

Post Reply