OpenVPN broken after Windows 10 creator update

Need help configuring your VPN? Just post here and you'll get that help.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
saturnotaku
OpenVpn Newbie
Posts: 1
Joined: Tue Apr 11, 2017 10:58 am

OpenVPN broken after Windows 10 creator update

Post by saturnotaku » Tue Apr 11, 2017 11:04 am

I realize that VPNs are a challenge on Windows 10, and apparently Microsoft has made it more difficult after its latest major update. I installed the new creator update on my system. I use the VPN.ac service and prior to the latest Windos update, I used the OpenVPN protocol without issue. After this update, something changed to where OpenVPN still connects, but is causing significant lag when browsing. Using Chrome, it frequently gets hung up on "resolving host." IT's happening across many websites, but is most prevalent on places like Amazon and eBay. Changing the connection protocol in the VPN.ac client software to L2TP/IPSec functions as a workaround, but I wanted to post my issue here so the OpenVPN team can look into it. I'm happy to provide additional information as needed. Thank you.

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 7841
Joined: Fri Jun 03, 2016 1:17 pm

Re: OpenVPN broken after Windows 10 creator update

Post by TinCanTech » Tue Apr 11, 2017 11:09 am

saturnotaku wrote:I'm happy to provide additional information as needed
Even though you never followed up with any further details, the Openvpn Developer Team discovered how Microsoft changed Windows with the Creators Update. They have also developed a new approach to resolving the problem.

Below is the minimum information we need if anybody else asks for help, more will be required following ..

Please see:
HOWTO: Request Help !

Please see:
HOWTO: Request Help ! {2}

eliotcougar
OpenVpn Newbie
Posts: 6
Joined: Sat Nov 19, 2016 2:17 pm

Re: OpenVPN broken after Windows 10 creator update

Post by eliotcougar » Wed Apr 12, 2017 10:29 pm

In my case OpenVPN is also broken... I use it to circumvent Russian Internet Blacklist... It adds several thousands routes when connecting to pass traffic through... After the Creators Update it still adds all the routes, but the traffic goes through my main connection anyway as if those routes don't exist...

I use OpenVPN 2.4.1 x64...

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 7841
Joined: Fri Jun 03, 2016 1:17 pm

Re: OpenVPN broken after Windows 10 creator update

Post by TinCanTech » Wed Apr 12, 2017 11:37 pm


eliotcougar
OpenVpn Newbie
Posts: 6
Joined: Sat Nov 19, 2016 2:17 pm

Re: OpenVPN broken after Windows 10 creator update

Post by eliotcougar » Wed Apr 19, 2017 3:28 pm

I've narrowed down my problem...
It turns out that on Windows 10 Creators Update the DHCP service fails randomly when assigning IP to the OpenVPN interface... And the same happens with regular connection to the router... Something is broken definitely...
When that happened, and OpenVPN interface didn't get IP address, the OpenVPN service was still adding my 40+ thousand routes... ...to the main network interface for some reason...

don.o
OpenVpn Newbie
Posts: 2
Joined: Mon Apr 24, 2017 3:44 pm

Re: OpenVPN broken after Windows 10 creator update

Post by don.o » Mon Apr 24, 2017 3:55 pm

I encountered the same issue whereby OpenVPN could no longer apply the IP address to the TAP interface after it was assigned by the OpenVPN DHCP server. This started happening right after I upgraded to Windows 10 Creator Build 15063.138.

I resolved the issue by running the cmd BAT file found in C:\Program Files\OpenVPN\bin called "deltapall.bat" (right-click and Run as administrator). This removes the TAP interface and driver.

Then, I restarted the system, this was "required" as it didn't work when I tried the next command without restarting.

Then I ran the cmd BAT file called "addtap.bat" found in the same folder (again, right-click and Run as administrator). This recreates the TAP interface and installs the driver.

mcreisinger
OpenVpn Newbie
Posts: 1
Joined: Mon May 01, 2017 5:20 pm

Re: OpenVPN broken after Windows 10 creator update

Post by mcreisinger » Mon May 01, 2017 5:21 pm

I ran the deltapall, then reboot, then addtap, and it did not fix it for me. Still bridged to main internet line. Also can access some resources through the VPN and not others.

codref
OpenVpn Newbie
Posts: 1
Joined: Tue May 02, 2017 10:29 am

Re: OpenVPN broken after Windows 10 creator update

Post by codref » Tue May 02, 2017 10:35 am

Had the same problem after the same Windows 10 Upgrade. Our VPN injects a DNS server and our local names were not resolved any more.
The solution was, on the LAN network interface, to disable IPv6 and to configure (not DHCP assigned) an external DNS server (not the one behind the VPN of course!)

TiTex
OpenVPN Super User
Posts: 315
Joined: Tue Apr 12, 2011 6:22 am

Re: OpenVPN broken after Windows 10 creator update

Post by TiTex » Tue May 02, 2017 10:52 am

i works just fine for me at work , win 10 enterprise x64 , openvpn 2.4
just had to reinstall the driver after the update and add the TAP adapter

don.o
OpenVpn Newbie
Posts: 2
Joined: Mon Apr 24, 2017 3:44 pm

Re: OpenVPN broken after Windows 10 creator update

Post by don.o » Mon May 08, 2017 11:07 pm

mcreisinger wrote:I ran the deltapall, then reboot, then addtap, and it did not fix it for me. Still bridged to main internet line. Also can access some resources through the VPN and not others.
While the issue on my system was resolved, for a bit, shortly after booting up, it stopped working again. Same as before, Windows couldn't assign an IP address to the TAP network interface.

Further troubleshooting and I've been able to resolve the issue again.

It appears my antivirus might have been causing the issue. I was running Avast Business. I performed the same "deltapall", then uninstalled Avast. On reboot, I ran the "addtap" command and OpenVPN is working properly now. Seems likely the issue is related to the firewall functions of Avast.

Hopefully, this resolution will stick. With more time, I may reinstall Avast to see if the issue returns. Since the functions Avast installs are "burned" into the installer by the company I work for, I won't be able to disable portions of it for troubleshooting.

vyasjisworld
OpenVpn Newbie
Posts: 1
Joined: Mon Oct 30, 2017 7:45 am

Re: OpenVPN broken after Windows 10 creator update

Post by vyasjisworld » Mon Oct 30, 2017 7:46 am

Team,

Please help me hear, My VPN is broken after Windows Creator Fall update, it failing to connect.
I use OpenVPN -2.4.4-I601 x64..

Thanks
Vyasjisworld

bounsy
OpenVpn Newbie
Posts: 1
Joined: Wed Nov 08, 2017 5:07 pm

Re: OpenVPN broken after Windows 10 creator update

Post by bounsy » Wed Nov 08, 2017 5:24 pm

OpenVPN also broke for me recently after the Windows 10 Creator Update. In order to fix it, I had to do the following:
  1. Open a command prompt in administrator mode. This is important, since the commands do not work correctly as a non-admin and can't be run as an admin from the program menu.
  2. Delete the current TAP configuration (if it is present, it was already absent on my system): "C:\Program Files\TAP-Windows\bin\deltapall.bat"
  3. Reboot to ensure that everything is updated correctly. This may not be 100% necessary here, but it doesn't hurt and other users seem to suggest that it was required for them.
  4. Log on and open a command prompt in administrator mode.
  5. Add the TAP configuration: "C:\Program Files\TAP-Windows\bin\addtap.bat"
  6. Reboot (yes, again) to ensure that everything is updated correctly. This was necessary for me in order to get it to work correctly. It didn't work until I rebooted after adding the TAP configuration.
  7. Log on and use OpenVPN normally.
Hopefully that helps someone else.

Holmeswood
OpenVpn Newbie
Posts: 1
Joined: Sun Mar 24, 2019 7:28 pm

Re: OpenVPN broken after Windows 10 creator update

Post by Holmeswood » Sun Mar 24, 2019 7:37 pm

I have recently "upgraded" Windows 10 to Creative. I have tried all of the published fixes to get OpenVPN back working, without success.
I am running a TUN server (OpenVPN version 2.4.7) which worked just fine before the "upgrade".
Connection establishes OK but no Internet. I have managed to revert to the previous Window 10 and all is well.
Looking forward, however, it would be nice to find out why this is happening.
I have basic understanding of TCP/IP and OpenVPN but can't fix this. Any help would be gratefully received.

IaanLouw
OpenVpn Newbie
Posts: 1
Joined: Sun May 12, 2019 12:36 pm

Re: OpenVPN broken after Windows 10 creator update

Post by IaanLouw » Sun May 12, 2019 12:37 pm

Hi - I have the same problem. I run
Sun May 12 09:04:36 2019 OpenVPN 2.4.7 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Apr 25 2019
Sun May 12 09:04:36 2019 Windows version 6.2 (Windows 8 or greater) 64bit
Sun May 12 09:04:36 2019 library versions: OpenSSL 1.1.0j 20 Nov 2018, LZO 2.10

Post Reply