An error occurred installing TAP device center

This forum is for all inquiries relating to the installation of OpenVPN from source and with binaries.
Forum rules
Please visit (and READ) the OpenVPN HowTo http://openvpn.net/howto prior to asking any questions in here!
Post Reply
laco09
OpenVpn Newbie
Posts: 3
Joined: Wed Sep 18, 2013 10:12 pm

An error occurred installing TAP device center

Post by laco09 » Wed Sep 18, 2013 10:14 pm

Hello,

"An error occurred installing TAP device center"

I'm having this problem during the install of openvpn.... I've tried everything so i came here to have some help.

I'm on Windows 7 64 bits. please :).

raptorjp
OpenVPN User
Posts: 31
Joined: Sun Sep 08, 2013 8:05 pm

Re: An error occurred installing TAP device center

Post by raptorjp » Wed Sep 18, 2013 11:07 pm

Are you installing with the 686 executable?
Try to run as admin, to see if that helps.

laco09
OpenVpn Newbie
Posts: 3
Joined: Wed Sep 18, 2013 10:12 pm

Re: An error occurred installing TAP device center

Post by laco09 » Thu Sep 19, 2013 11:23 am

I already tried this, still get the message during the install

raptorjp
OpenVPN User
Posts: 31
Joined: Sun Sep 08, 2013 8:05 pm

Re: An error occurred installing TAP device center

Post by raptorjp » Fri Sep 20, 2013 2:28 am

What does it say right before you get the error? Is a dialog box that pops up and that is the only message? If I remember correctly there is a status log that displays what is happening. Maybe post this?

A while ago I had a similar problem on XP.

Disable antivirus?
Disable UAC?

Are you reinstalling or upgrading a previous openvpn installation? If so, make sure everything is deleted before reinstall.

laco09
OpenVpn Newbie
Posts: 3
Joined: Wed Sep 18, 2013 10:12 pm

Re: An error occurred installing TAP device center

Post by laco09 » Fri Sep 20, 2013 6:47 am

....
Extract: INSTALL -win32.txt... 100%
Extract: COPYRIGHT.GPL... 100%
Extract: icon.ico... 100%
tapinstall hwids returned: 0
TAP UPDATE
Updating drivers for tap0901 from C:\Program Files (x86)\OpenVPN\driver\Oemwin2k.inf.
tapinstall.exe failed
tapinstall update returned: 2
tapinstall cumulative status: 2

.......

raptorjp
OpenVPN User
Posts: 31
Joined: Sun Sep 08, 2013 8:05 pm

Re: An error occurred installing TAP device center

Post by raptorjp » Fri Sep 20, 2013 4:19 pm

laco09 wrote:....
Extract: INSTALL -win32.txt... 100%
Extract: COPYRIGHT.GPL... 100%
Extract: icon.ico... 100%
tapinstall hwids returned: 0
TAP UPDATE
Updating drivers for tap0901 from C:\Program Files (x86)\OpenVPN\driver\Oemwin2k.inf.
tapinstall.exe failed
tapinstall update returned: 2
tapinstall cumulative status: 2

.......
That looks interesting. Why are you installing into the x86 directory? I am running win7 64 and it installs into the non-x86 directory. Did you completely delete the program files(x86)/openvpn directory before you tried to reinstall?

Do a complete uninstall and delete any openvpn directories. Then use the current stable version (not the x86_64 but the x686 version). Maybe it is looking there first when it is either not in that location or there is an older installation that you have.

dmarlatt
OpenVpn Newbie
Posts: 1
Joined: Fri Sep 23, 2011 6:16 pm

Re: An error occurred installing TAP device center

Post by dmarlatt » Thu Oct 03, 2013 8:04 pm

Experienced this error on Windows Home x64

OpenVPN installation: Unable to install TUN/TAP driver. Exit code 2

Noticed the Network Adapters was empty under "Change Adapters Settings" even though the adapter was running and working.

Locate and then delete the following registry subkey:

HKEY_LOCAL-MACHINE\SYSTEM\CurrentControlSet\Control\Network\Config

mmangus
OpenVpn Newbie
Posts: 3
Joined: Fri Apr 17, 2015 12:15 am

Re: An error occurred installing TAP device center

Post by mmangus » Fri Apr 17, 2015 12:35 am

I'm having the exact same problem. I tried looking for the indicated subkey but its not there. I deleted the \Program Files (x86)\OpenVPN directory as I'm running Windows x64 as well. I also noticed it is attempting and failing to create a device every time I run the install the result is an "unknown device" under Network Adapters in Device Manager.

The exact text of the error message is:

Unable to install TUN/TAP driver. Exit code: 2

openvpnuser2000
OpenVpn Newbie
Posts: 3
Joined: Thu Oct 19, 2017 11:53 am

Re: An error occurred installing TAP device center

Post by openvpnuser2000 » Thu Oct 19, 2017 11:54 am

The same problem for me

openvpnuser2000
OpenVpn Newbie
Posts: 3
Joined: Thu Oct 19, 2017 11:53 am

Re: An error occurred installing TAP device center

Post by openvpnuser2000 » Thu Oct 19, 2017 4:27 pm

In safe mode I also get error installing TAP device

openvpnuser2000
OpenVpn Newbie
Posts: 3
Joined: Thu Oct 19, 2017 11:53 am

Re: An error occurred installing TAP device center

Post by openvpnuser2000 » Fri Oct 20, 2017 7:43 am

I have done everything that I find in internet.

I don`t have antivirus software, windows defender is also disabled.
I have tried manually install TAP driver, use different versions - nothing works.

eneerge
OpenVpn Newbie
Posts: 1
Joined: Tue Jul 03, 2018 9:52 pm

Re: An error occurred installing TAP device center

Post by eneerge » Tue Jul 03, 2018 9:56 pm

So, I've had this issue numerous times and I just had it again. However, the fix I posted on the official bug report here https://community.openvpn.net/openvpn/ticket/592 worked again for me.

I stopped all virtualization software and kicked off the install again (didnt even have to reboot). The install went through just fine. The only virtualization software I use is VirtualBox and Sandboxie. I stopped Virtualbox machines and closed all Sandboxie Sandboxes.

It's most likely a driver conflict with another software. It's easily reproducible by just using the above software. I'm guessing it's mostly Sandboxie in my case. It may be something similar for everyone else. Check all of the services you have running in services.msc. Another way to try and help diagnose it would be using Process Monitor to monitor any errors that appear to come from the installer while you're installing.

BTW, this was with the latest version as of July 3, 2018: 2.4.6.

Post Reply