Trouble connecting with Laptop

Post Reply
raylo32
OpenVpn Newbie
Posts: 9
Joined: Fri Dec 14, 2018 12:02 am

Trouble connecting with Laptop

Post by raylo32 » Fri Dec 14, 2018 12:09 am

I didn't see a forum area for the Windows PC Connect app so I ask here. I successfully set up OpenVPN Connect on my iPhone XR to access my home network on a Linksys 1900 ACS router. But the PC Connect app will not connect, I keep getting authentication error. Profile file saved to the laptop and directly imported, User ID and password double and triple checked. Here is part of the log file:



Thu Dec 13 18:27:02 2018 Thu Dec 13 18:27:02 2018 OpenVPN Management Interface 1.0.0/3.git:master win x86_64 64-bit [MbedTLS] built on Jun 8 2018 09:46:29
Thu Dec 13 18:27:02 2018 Thu Dec 13 18:27:02 2018 OMI Connecting to [127.0.0.1]:53053 [tcp]
Thu Dec 13 18:27:14 2018 Thu Dec 13 18:27:14 2018 Frame=512/2048/512 mssfix-ctrl=1250
Thu Dec 13 18:27:14 2018 Thu Dec 13 18:27:14 2018 UNUSED OPTIONS
4 [resolv-retry] [infinite]
5 [nobind]
6 [persist-key]
7 [persist-tun]
10 [verb] [3]
Thu Dec 13 18:27:14 2018 Thu Dec 13 18:27:14 2018 RESOLVE
Thu Dec 13 18:27:14 2018 Thu Dec 13 18:27:14 2018 Contacting 75.213.48.11:1194 via UDP
Thu Dec 13 18:27:14 2018 Thu Dec 13 18:27:14 2018 WAIT
Thu Dec 13 18:27:14 2018 Thu Dec 13 18:27:14 2018 Connecting to [75.213.48.11]:1194 (75.213.48.11) via UDPv4
Thu Dec 13 18:27:14 2018 Thu Dec 13 18:27:14 2018 CONNECTING
Thu Dec 13 18:27:14 2018 Thu Dec 13 18:27:14 2018 Tunnel Options:V4,dev-type tun,link-mtu 1541,tun-mtu 1500,proto UDPv4,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-client
Thu Dec 13 18:27:14 2018 Thu Dec 13 18:27:14 2018 Creds: Username/Password
Thu Dec 13 18:27:14 2018 Thu Dec 13 18:27:14 2018 Peer Info:
IV_GUI_VER=ovpnmi 1.0.0
IV_VER=3.git:master
IV_PLAT=win
IV_NCP=2
IV_TCPNL=1
IV_PROTO=2
UV_ASCLI_VER=2.6.0.100
UV_PLAT_REL=Windows 10 Home_6.3.17134
IV_BS64DL=1

Thu Dec 13 18:27:14 2018 Thu Dec 13 18:27:14 2018 VERIFY OK : depth=0
cert. version : 3
serial number : 01
issuer name : C=US, ST=CA, L=Irvine, O=Linksys, OU=Belkin, CN=Mamba, ??=BlackMamba, emailAddress=support@linksys.com
subject name : C=US, ST=CA, L=Irvine, O=Linksys, OU=Belkin, CN=Mamba, ??=BlackMamba, emailAddress=support@linksys.com
issued on : 2012-10-11 06:00:46
expires on : 2022-10-09 06:00:46
signed using : RSA with SHA1
RSA key size : 1024 bits
basic constraints : CA=false
cert. type : SSL Server
key usage : Digital Signature, Key Encipherment
ext key usage : TLS Web Server Authentication

Thu Dec 13 18:27:15 2018 Thu Dec 13 18:27:15 2018 SSL Handshake: TLSv1.0/TLS-DHE-RSA-WITH-3DES-EDE-CBC-SHA
Thu Dec 13 18:27:15 2018 Thu Dec 13 18:27:15 2018 Session is ACTIVE
Thu Dec 13 18:27:15 2018 Thu Dec 13 18:27:15 2018 GET_CONFIG
Thu Dec 13 18:27:15 2018 Thu Dec 13 18:27:15 2018 Sending PUSH_REQUEST to server...
Thu Dec 13 18:27:15 2018 Thu Dec 13 18:27:15 2018 AUTH_FAILED
Thu Dec 13 18:27:15 2018 Thu Dec 13 18:27:15 2018 AUTH_FAILED [FATAL-ERR]
Thu Dec 13 18:27:15 2018 Thu Dec 13 18:27:15 2018 DISCONNECTED
Thu Dec 13 18:27:15 2018 Thu Dec 13 18:27:15 2018 OpenVPN Management Interface 1.0.0/3.git:master win x86_64 64-bit [MbedTLS] built on Jun 8 2018 09:46:29
Thu Dec 13 18:27:15 2018 Thu Dec 13 18:27:15 2018 OMI Connecting to [127.0.0.1]:50375 [tcp]
Thu Dec 13 18:27:35 2018 Thu Dec 13 18:27:35 2018 Frame=512/2048/512 mssfix-ctrl=1250
Thu Dec 13 18:27:35 2018 Thu Dec 13 18:27:35 2018 UNUSED OPTIONS
4 [resolv-retry] [infinite]
5 [nobind]
6 [persist-key]
7 [persist-tun]
10 [verb] [3]

raylo32
OpenVpn Newbie
Posts: 9
Joined: Fri Dec 14, 2018 12:02 am

Re: Trouble connecting with Laptop

Post by raylo32 » Fri Dec 14, 2018 11:07 am

Just to be clear, I am using the built in native OpenVPN server in the Linksys 1900 ACS. I can successfully connect via iOS app on my phone from the 4G LTE cellular (wifi off) but only get "authentication failed" when I try from my Windows laptop tethered to the phone hotspot so the laptop is not on the same LAN as the Linksys. Using the same cert and login credentials. Not trying to connect both simultaneously. Also, the WAN ip address in the log file is fictitious in case a moderator was going to tell me to scrub that.

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 5922
Joined: Fri Jun 03, 2016 1:17 pm

Re: Trouble connecting with Laptop

Post by TinCanTech » Fri Dec 14, 2018 1:10 pm

Check your server log file ..

raylo32
OpenVpn Newbie
Posts: 9
Joined: Fri Dec 14, 2018 12:02 am

Re: Trouble connecting with Laptop

Post by raylo32 » Fri Dec 14, 2018 6:40 pm

The router doesn't have a dedicated VPN server log. Alls it has are (1) logs of incoming ip addresses/ports and (2) outgoing LAN address, destination URL/ip and service/port #. Not sure what I need to look for or if anything in these logs would be helpful??

raylo32
OpenVpn Newbie
Posts: 9
Joined: Fri Dec 14, 2018 12:02 am

Re: Trouble connecting with Laptop

Post by raylo32 » Tue Dec 18, 2018 10:22 am

This issue is solved. Apparently I installed the wrong version of the OpenVPN client on my laptop. Got the 2.4.6 download and now works perfectly.

Post Reply