openVPN not in Windows10 due to bad TAP-Windows?

Need help configuring your VPN? Just post here and you'll get that help.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
nemelaer
OpenVpn Newbie
Posts: 7
Joined: Fri Aug 10, 2018 11:20 pm

openVPN not in Windows10 due to bad TAP-Windows?

Post by nemelaer » Fri Aug 10, 2018 11:38 pm

Hello, after a whole day puzzling without solution i ask for help.
I have a Netgear NightHawk router R7000 and with their updated certificates for VPN service with OpenVPN I have my iPad pro (IOS) as well as my Samsung Galaxy phone (android) up and running perfectly as clients to my router, on which the VPN server is running (with mynetgear.com as the provider).
To my surprise, though, it seems impossible to get my Windows 10 (64 bits) ASUS Zenbook laptop up to the same level. After installing the OpenVPN GUI (the newest as well as the "last stable") I get (visible in the log) the message "WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info."
Might it be something with the cooperation between the TAP-Windows adapter and my laptop, which has NO ethernet connection and only WiFi? In the adapter screen I notice that the (renamed) NETGEAR-VPN, the connection with the TAP-Windows adapter, needs the ethernet cable to be attached. (Needless to say that the field "Connected to the internet" stays blank....)
Any suggestions? Anyone?
Thanks for listening!

Nemelaer

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 4806
Joined: Fri Jun 03, 2016 1:17 pm

Re: openVPN not in Windows10 due to bad TAP-Windows?

Post by TinCanTech » Sat Aug 11, 2018 1:32 am

nemelaer wrote:
Fri Aug 10, 2018 11:38 pm
the message "WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info."
It means exactly what it says ..

You must enable some kind of security to verify that the remote site you are connecting to
is in fact what it claims to be and not an imposter ..

nemelaer
OpenVpn Newbie
Posts: 7
Joined: Fri Aug 10, 2018 11:20 pm

Re: openVPN not in Windows10 due to bad TAP-Windows?

Post by nemelaer » Sat Aug 11, 2018 7:05 am

Thanks for answering. But i do not onderstand why this would be only a Windows issue (the connection, with the same keys and certificates, is flawless in IOS and Android). But apart from that: how to build in that kind of security? I am afraid that I haven't got the skills to do that. Or is there a simple way to actieve this?

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 4806
Joined: Fri Jun 03, 2016 1:17 pm

Re: openVPN not in Windows10 due to bad TAP-Windows?

Post by TinCanTech » Sat Aug 11, 2018 12:34 pm

Try reading the link provided ..........

nemelaer
OpenVpn Newbie
Posts: 7
Joined: Fri Aug 10, 2018 11:20 pm

Re: openVPN not in Windows10 due to bad TAP-Windows?

Post by nemelaer » Sat Aug 11, 2018 1:58 pm

I read it al right, that’s why i am afraid i juist haven’t the skills to do that. Apart from that, since my router acts as the VPN-server, i think i am not even allowed to mess with the router, plus i would not know where exactly to installe the server certificate.
Maybe i should ask netgear about this all...
But thanks a lot anyhow for thinking along! And might you have some otter suggestions, please let me know! My knowledge improves with every comment (and of course there is a lot room for improvement!)

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 4806
Joined: Fri Jun 03, 2016 1:17 pm

Re: openVPN not in Windows10 due to bad TAP-Windows?

Post by TinCanTech » Sat Aug 11, 2018 2:08 pm

nemelaer wrote:
Sat Aug 11, 2018 1:58 pm
I read it al right, that’s why i am afraid i juist haven’t the skills to do that
You add one line of code to the config file ..
nemelaer wrote:
Sat Aug 11, 2018 1:58 pm
i think i am not even allowed to mess with the router
Then speak to the person who is allowed.

nemelaer
OpenVpn Newbie
Posts: 7
Joined: Fri Aug 10, 2018 11:20 pm

Re: openVPN not in Windows10 due to bad TAP-Windows?

Post by nemelaer » Sat Aug 11, 2018 10:49 pm

His/her name is Netgear and i will (I think that you"ll understand the concept of the impossibility for end users to change root programs / software of Netgear routers).
If this leads to a solution i'll report about it at this place.

nemelaer
OpenVpn Newbie
Posts: 7
Joined: Fri Aug 10, 2018 11:20 pm

Re: openVPN not in Windows10 due to bad TAP-Windows?

Post by nemelaer » Sat Aug 11, 2018 10:53 pm

And by the way, i added the line you are refering to, even before starting this topic. It only made things worse, the connection did not even start up!

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 4806
Joined: Fri Jun 03, 2016 1:17 pm

Re: openVPN not in Windows10 due to bad TAP-Windows?

Post by TinCanTech » Sat Aug 11, 2018 11:59 pm

nemelaer wrote:
Sat Aug 11, 2018 10:53 pm
by the way, i added the line you are refering to, even before starting this topic
So this topic is null and void ..

Or would you like to get to the point ?

nemelaer
OpenVpn Newbie
Posts: 7
Joined: Fri Aug 10, 2018 11:20 pm

Re: openVPN not in Windows10 due to bad TAP-Windows?

Post by nemelaer » Sun Aug 12, 2018 9:16 am

TinCanTech, i try to be and stay polite...
I think the point is perfectly clear. I can’t get my Windows 10 VPN connection to work, contrary to the IOS and Android connections, which work flawlessly. As an end user I can’t install a server certificate on my Netgear router, and I read the link in the OpenVPN.net/howto concerning the mitm and tried the extra line in my config (client1.ovpn), to no avail. That is also why I thougt it might be a TAP-Windows problem, which I mentioned in the title in this topic.
The topic is not null and void, because i experience a problem which until now is not solved. I like to think that this forum is meant for these questions.
I appreciate your responses. Your last remarks may express the difference between us regarding technical skills and knowhow, and that is the reason why i ask questions and you give answers. Sorry that you are apparently getting impatient.

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 4806
Joined: Fri Jun 03, 2016 1:17 pm

Re: openVPN not in Windows10 due to bad TAP-Windows?

Post by TinCanTech » Sun Aug 12, 2018 5:39 pm

nemelaer wrote:
Sun Aug 12, 2018 9:16 am
I can’t get my Windows 10 VPN connection to work
It works but with a warning ..
nemelaer wrote:
Sun Aug 12, 2018 9:16 am
As an end user I can’t install a server certificate on my Netgear router
We can't help with that.
nemelaer wrote:
Sun Aug 12, 2018 9:16 am
tried the extra line in my config (client1.ovpn), to no avail
You need the server cert to be correctly signed and loaded into your server.
nemelaer wrote:
Sun Aug 12, 2018 9:16 am
That is also why I thougt it might be a TAP-Windows problem, which I mentioned in the title in this topic.
It has nothing to do with the tap adapter.
nemelaer wrote:
Sun Aug 12, 2018 9:16 am
The topic is not null and void, because i experience a problem which until now is not solved
And according to what you have written:
nemelaer wrote:
Sun Aug 12, 2018 9:16 am
As an end user I can’t install a server certificate on my Netgear router
you cannot solve this.
nemelaer wrote:
Sun Aug 12, 2018 9:16 am
Sorry that you are apparently getting impatient
This is me trying to help you by answering your question.

This is me when I get impatient:
HOWTO: Request Help ! {2}

nemelaer
OpenVpn Newbie
Posts: 7
Joined: Fri Aug 10, 2018 11:20 pm

Re: openVPN not in Windows10 due to bad TAP-Windows?

Post by nemelaer » Mon Aug 13, 2018 12:31 am

thanks again, and now extra because you really put some time in answering the newbie i am.
Reading your links about howto request help, I am afraid that, in my router, I can't find the probable deeply hidden server certificate or related software /code. So I can't provide all the info you would need to help, and I won't ask you to put more time in this. I'll contact the Netgear people, because there is the chance that, while IOS and Android cause no problems, it is the Windows 10 connection that does not work. And of course, the server certificate is on their side.
And by the way, it really does not work, it is not just the warning. No connection comes off the ground at all.
As promised, because i started this topic, i shall post here the solution, if it comes.
If you think it useful that i send to you only my client config .ovpn file and the client log lines, i will happily send them, also information about / screenshots of my router settings if that would help.
Anyhow, thanks for your help, I really appreciate it.

Post Reply