Client will not open browser to authenticate

Official client software for OpenVPN Access Server and OpenVPN Cloud.
Post Reply
ariscol
OpenVpn Newbie
Posts: 1
Joined: Thu Feb 16, 2023 2:56 pm

Client will not open browser to authenticate

Post by ariscol » Thu Feb 16, 2023 3:00 pm

I setup a new windows 11 machine yesterday, installed OpenVPN Connect (3.33.6.2752), and when I click connect, it says, "Please proceed with authentication in your system browser," as expected, but nothing happens. It never opens the browser.

I've tried everything I can think of:
* Browser open, browser closed
* Multiple browsers (chrome, edge, firefox) open
* Deleting app and reinstalling
* Deleting profile and recreating

Help?

User avatar
JosephS
OpenVPN Inc.
Posts: 51
Joined: Fri Feb 17, 2023 5:15 pm

Re: Client will not open browser to authenticate

Post by JosephS » Fri Feb 17, 2023 5:20 pm

Try toggling the default browser in your windows settings, it should fix the issue:

Go to Windows Settings > Apps > Default Apps > Set a browser as a default browser (doesn't matter which one)

Next time you connect it should open the authentication page in the browser.

fileark
OpenVpn Newbie
Posts: 1
Joined: Mon Nov 27, 2023 9:57 pm

Re: Client will not open browser to authenticate

Post by fileark » Mon Nov 27, 2023 10:02 pm

I have the same issue, yes a default browser is selected in windows settings. I reinstalled, tried to set other browsers to default, ran as administrator. When setting up a new profile it states "Please proceed with authentication in your system browser". Clicking the "Sign In" button nothing happens at all.
It works fine on another computer I tested with two different VPN profiles. I actually already had a profile set up so I wondered how it worked before. I deleted the old profile now I can't set it back up, obviously it worked the first time (maybe a week ago)

Is there a way to get an older version of OPENVPNConnect? I can't find one anywhere.

OpenVPN-Connect-3.4.2.3160
Windows 11 Pro

User avatar
JosephS
OpenVPN Inc.
Posts: 51
Joined: Fri Feb 17, 2023 5:15 pm

Re: Client will not open browser to authenticate

Post by JosephS » Tue Dec 19, 2023 9:10 am

Hi fileark,

You would need to manually togle between default browsers (even if it already has one selected).

Also, another approach would be to to manually specify a browser for HTTPS type links:

Settings > Apps > Default Apps > Select a browser > Set default file types or link types > HTTPS > Select a browser.

I hope this helps.

Regards,
Joseph

Post Reply