Real IP not being logged

Business solution to host your own OpenVPN server with web management interface and bundled clients.
Post Reply
emb531
OpenVpn Newbie
Posts: 2
Joined: Fri Dec 09, 2022 4:00 am

Real IP not being logged

Post by emb531 » Fri Dec 09, 2022 4:04 am

Hello, I am running the OpenVPN ESXI appliance.

Version is 2.11.1

Real IP Is not being logged under Log Reports, however the Real IP is shown while a user is connected under Current Users

I added DEBUG_LOGDB=1 to the as.conf file as described here (https://openvpn.net/vpn-server-resource ... ss-server/) and can see the Real IP is not being logged there as well.

I deployed a new instance of the appliance which comes with version 2.8.5 and Real IP logging does work on this version

So sometime in-between these versions it was broke

Thank you and I can provide any logs or more info if needed

User avatar
openvpn_inc
OpenVPN Inc.
Posts: 1133
Joined: Tue Feb 16, 2021 10:41 am

Re: Real IP not being logged

Post by openvpn_inc » Fri Dec 09, 2022 11:46 am

Hello emb531,

We know. It's a minor regression introduced in 2.11.1. We have 2.11.2 in the works that will resolve this.

Kind regards,
Johan
Image OpenVPN Inc.
Answers provided by OpenVPN Inc. staff members here are provided on a voluntary best-effort basis, and no rights can be claimed on the basis of answers posted in this public forum. If you wish to get official support from OpenVPN Inc. please use the official support ticket system: https://openvpn.net/support

emb531
OpenVpn Newbie
Posts: 2
Joined: Fri Dec 09, 2022 4:00 am

Re: Real IP not being logged

Post by emb531 » Fri Dec 09, 2022 6:52 pm

Thank you for confirming and I will look forward to the next release

Post Reply