Access Server only 100 Mbit

Business solution to host your own OpenVPN server with web management interface and bundled clients.
Post Reply
Pfann
OpenVpn Newbie
Posts: 5
Joined: Fri Nov 25, 2022 10:44 am

Access Server only 100 Mbit

Post by Pfann » Fri Nov 25, 2022 10:47 am

Hello. I installed the Access Server by the installer.

All configs are default. The Problem is, whatever i try the connection stay on 100 Mbit.

To prevent some comments

the root got 1gbit and is hosted by hetzner and the other one on netcup ( both 1 gbit )

i tested it with a 1gbit rootserver (clientsite) and 1 gbit Vserver ( server )

I tryed google, but i get only normal openvpn infos and config file, but nothing for the Access server.

Maybe anyone can help me with that ?=

User avatar
openvpn_inc
OpenVPN Inc.
Posts: 1116
Joined: Tue Feb 16, 2021 10:41 am

Re: Access Server only 100 Mbit

Post by openvpn_inc » Sun Nov 27, 2022 10:44 am

Hello Pfann,

OpenVPN does encrypt and decrypt data, so there can be a bottleneck there in terms of processing speed. There is also the usual bottleneck of network speed, and firewall/antivirus, the application used to test, packet size, and so on. Also the available bandwidth on the other side. Also the traffic path you do - are you sending something from your VPN client to the VPN server and from there to another server? That means the server has twice the traffic to deal with. Also other users of bandwidth/OpenVPN at the same time can affect things. And being on shared hardware can affect things too. So the reasons for things being slower than you expect are pretty broad. However on reasonably modern hardware even with a single-thread OpenVPN2 process it should be possible to get like 650Mbps with AES-256-GCM, which Access Server uses by default now. Maybe not directly over the Internet but local network that should be doable. And that's even without the DCO kernel acceleration that's in development now.

You could try some things like doing a local OpenVPN connection (but be careful with routing not to lock yourself out of access to your server), and doing that with a client in the same network. And testing the connection without OpenVPN as well, turning firewalls off, and so on. And also just reaching out to Hetzner and asking them what's up, they might have some firewall or rate limiting rules in place, or maybe they have some suggestions on their particular systems to get things working nicely.

As an example though I've got an Access Server on a dirt-cheap Debian 11 VPS (3 bucks a month or so) and easily get over 500Mbps on that. So it is possible, but... there are many factors. So it's hard for me to give you a single answer, but I can only inform you of a number of items that could be the problem and to investigate those and try to eliminate things by testing.

Good luck,
Johan
Image OpenVPN Inc.
Answers provided by OpenVPN Inc. staff members here are provided on a voluntary best-effort basis, and no rights can be claimed on the basis of answers posted in this public forum. If you wish to get official support from OpenVPN Inc. please use the official support ticket system: https://openvpn.net/support

Pfann
OpenVpn Newbie
Posts: 5
Joined: Fri Nov 25, 2022 10:44 am

Re: Access Server only 100 Mbit

Post by Pfann » Sun Nov 27, 2022 12:21 pm

Thank you for your Reply. Ya the Server is on a little Vserver, but also i tested on an AMD ryzon, so the hardware is not the reason.

the plan was to take the IPv4 from the Vserver to have a static ipv4 at home ( in germany we dont have a static ip )

the only problem is the speed. Im new to this VPN things, thats why i choosed Access Server. It has easy setup for newbies like me and it works great until you want more then 100 mbit

User avatar
openvpn_inc
OpenVPN Inc.
Posts: 1116
Joined: Tue Feb 16, 2021 10:41 am

Re: Access Server only 100 Mbit

Post by openvpn_inc » Sun Nov 27, 2022 2:27 pm

Hello Pfann,

It works very well above 100Mbps too but there's something in your situation that is not currently known and I'm not able to diagnose it remotely without more information.

Good luck,
Johan
Image OpenVPN Inc.
Answers provided by OpenVPN Inc. staff members here are provided on a voluntary best-effort basis, and no rights can be claimed on the basis of answers posted in this public forum. If you wish to get official support from OpenVPN Inc. please use the official support ticket system: https://openvpn.net/support

Pfann
OpenVpn Newbie
Posts: 5
Joined: Fri Nov 25, 2022 10:44 am

Re: Access Server only 100 Mbit

Post by Pfann » Sun Nov 27, 2022 3:02 pm

OFC. tell me what infos you need, and maybe how i can get that infos

User avatar
openvpn_inc
OpenVPN Inc.
Posts: 1116
Joined: Tue Feb 16, 2021 10:41 am

Re: Access Server only 100 Mbit

Post by openvpn_inc » Sun Nov 27, 2022 8:08 pm

Hi Pfann,

You can check all the possible items I listed in my first response. Basically, do some basic debugging steps to figure out where the bottleneck is in your particular situation. Even just figuring out if it's a server or client side issue is already a big step.

Kind regards,
Johan
Image OpenVPN Inc.
Answers provided by OpenVPN Inc. staff members here are provided on a voluntary best-effort basis, and no rights can be claimed on the basis of answers posted in this public forum. If you wish to get official support from OpenVPN Inc. please use the official support ticket system: https://openvpn.net/support

Pfann
OpenVpn Newbie
Posts: 5
Joined: Fri Nov 25, 2022 10:44 am

Re: Access Server only 100 Mbit

Post by Pfann » Sun Nov 27, 2022 8:20 pm

okay. local i did not tryed, but i use clien version 3.+

i tryed some chispser Chacha20-Poly1305:AES-256-GCM:AES-128-GCM:AES-256-CBC nothing changed

also i added in the config some things, but idk what i did u can see the screenshot

https://i.imgur.com/uWRV95u.png



right now i make a new Vserver (debian 11 ) lets see on fresh install

User avatar
openvpn_inc
OpenVPN Inc.
Posts: 1116
Joined: Tue Feb 16, 2021 10:41 am

Re: Access Server only 100 Mbit

Post by openvpn_inc » Sun Nov 27, 2022 8:34 pm

Hi Pfann,

So the cipher isn't really the problem, I'm on default configuration and get 500+ Mbps just fine.

The config file you reference contains nothing that has any effect on the OpenVPN connection itself, it is a configuration file for the OpenVPN Access Server's management programs. Generally you do not edit the as.conf. Things that affect the VPN connection are configured through the web interface normally.

I think you might be better off contacting our support ticket system and requesting that someone tries some things with you to figure out where the bottleneck is. But I can assure you, it is not the OpenVPN Access Server program itself.

Kind regards,
Johan
Image OpenVPN Inc.
Answers provided by OpenVPN Inc. staff members here are provided on a voluntary best-effort basis, and no rights can be claimed on the basis of answers posted in this public forum. If you wish to get official support from OpenVPN Inc. please use the official support ticket system: https://openvpn.net/support

Pfann
OpenVpn Newbie
Posts: 5
Joined: Fri Nov 25, 2022 10:44 am

Re: Access Server only 100 Mbit

Post by Pfann » Sun Nov 27, 2022 9:38 pm

okay i fresh installed it. ( Debian 11 )

i used the guide from https://as-portal.openvpn.com/get-access-server/debian

https://i.imgur.com/gB2KF79.png



and still 100 Mbit



i did not touch anything, i just installed it, and tryed



Edit: i also tryed the option 2. same problem

Post Reply