OPENVPN Connect Mac Safari not working

Official client software for OpenVPN Access Server and OpenVPN Cloud.
Post Reply
toggee
OpenVpn Newbie
Posts: 1
Joined: Wed Sep 21, 2022 4:56 pm

OPENVPN Connect Mac Safari not working

Post by toggee » Wed Sep 21, 2022 4:58 pm

Hi,

I have configured my Synology NAS and can connect via the OpenVPN Connect app from my Macbook Pro and chrome works fine but Safari wont load any pages?

Any ideas?

Andrew

User avatar
openvpn_inc
OpenVPN Inc.
Posts: 1037
Joined: Tue Feb 16, 2021 10:41 am

Re: OPENVPN Connect Mac Safari not working

Post by openvpn_inc » Wed Sep 21, 2022 5:09 pm

Hello toggee/Andrew,

Pretty hard to say without any further details. I'm guessing it's the simple case of a DNS server being pushed that just doesn't work right, and Chrome might be able to work around that while Safari can't. Really hard to say without any further details. You could check the client side log to see if a DNS server is being pushed. You could check Synology configuration if pushing a DNS server can be switched off or if you can push a custom DNS server that works properly in the circumstances that matter.

Kind regards,
Johan
Image OpenVPN Inc.
Answers provided by OpenVPN Inc. staff members here are provided on a voluntary best-effort basis, and no rights can be claimed on the basis of answers posted in this public forum. If you wish to get official support from OpenVPN Inc. please use the official support ticket system: https://openvpn.net/support

TomasHamal
OpenVpn Newbie
Posts: 1
Joined: Thu Dec 01, 2022 2:18 pm

Re: OPENVPN Connect Mac Safari not working

Post by TomasHamal » Thu Dec 01, 2022 2:22 pm

Hello,

we're having the similar problem with safari, we are running OpenVPN on an Ubuntu server, and the problems does not look to me as relevant to DNS. Other browser work as expected. So I am trying to debug this issue.

Till now I found, that something blocks the request from processing and I am searching for some relevant information using wireshark:
Image

There are now entries in OpenVPN log, on server or client.

I doubt it is a OpenVPN problem, rather in Safari, but we need to find a cause and report it to the corresponding party

Post Reply