Unable to turn split tunnel off

Next-generation cloud-hosted OpenVPN business solution.
Post Reply
cradice
OpenVpn Newbie
Posts: 1
Joined: Tue May 04, 2021 11:52 pm

Unable to turn split tunnel off

Post by cradice » Tue May 04, 2021 11:57 pm

I am trying to set up OpenVPN Cloud to enable a static IP address for allow listing for certain services, but I am unable to turn off split tunneling with OpenVPN Cloud - which obviously then does not allow for one unified static public IP address. I have followed the below steps so far:
1. Sign in to the OpenVPN Cloud administration portal at https://cloud.openvpn.com.

2. Access Networks and edit the network that is to be set up as VPN Egress.

3. Toggle the Allow VPN Egress switch to ON

4. Click the OK button to dismiss the confirmation dialog shown to remind you to set up the connector instance to properly act as an internet gateway. See, HQ Network being used as egress route for OpenVPN Cloud

5. Click on the Save button in order to save the Network changes.

6. The VPN Egress is now ON for the selected Network

7. Then proceed on, installing the Connector and act as the Internet Gateway with a public IP address of your connector instance.
See, Connecting Networks to OpenVPN Cloud Using Connectors on how to install Connectors and the corresponding settings to enable NAT and routing. We recommend using Linux operating system.
https://openvpn.net/cloud-docs/connecti ... onnectors/

8. After the Network came online, you need to change the Internet Access setting for User Groups to Split Tunnel OFF.
See, Changing User Group’s Internet Access: https://openvpn.net/cloud-docs/changing ... t-gateway/
Unfortunately, when I get to step 8 the option to turn split tunneling off, the option is not allowed. The option is stuck at "Spilt Tunnel On" with the drop-down not clickable/greyed out. I am unsure what to do from here to resolve the issue.

User avatar
openvpn_inc
OpenVPN Inc.
Posts: 696
Joined: Tue Feb 16, 2021 10:41 am

Re: Unable to turn split tunnel off

Post by openvpn_inc » Wed May 05, 2021 7:27 pm

Hi Christian,

The changes should be for User Groups settings to set Split Tunnel OFF and make sure to keep Egress enabled on your network settings.
See, Changing User Group’s Internet Access: https://openvpn.net/cloud-docs/changing ... t-gateway/
cradice wrote:
Tue May 04, 2021 11:57 pm
I am trying to set up OpenVPN Cloud to enable a static IP address for allow listing for certain services, but I am unable to turn off split tunneling with OpenVPN Cloud - which obviously then does not allow for one unified static public IP address. I have followed the below steps so far:
1. Sign in to the OpenVPN Cloud administration portal at https://cloud.openvpn.com.

2. Access Networks and edit the network that is to be set up as VPN Egress.

3. Toggle the Allow VPN Egress switch to ON

4. Click the OK button to dismiss the confirmation dialog shown to remind you to set up the connector instance to properly act as an internet gateway. See, HQ Network being used as egress route for OpenVPN Cloud

5. Click on the Save button in order to save the Network changes.

6. The VPN Egress is now ON for the selected Network

7. Then proceed on, installing the Connector and act as the Internet Gateway with a public IP address of your connector instance.
See, Connecting Networks to OpenVPN Cloud Using Connectors on how to install Connectors and the corresponding settings to enable NAT and routing. We recommend using Linux operating system.
https://openvpn.net/cloud-docs/connecti ... onnectors/

8. After the Network came online, you need to change the Internet Access setting for User Groups to Split Tunnel OFF.
See, Changing User Group’s Internet Access: https://openvpn.net/cloud-docs/changing ... t-gateway/
Unfortunately, when I get to step 8 the option to turn split tunneling off, the option is not allowed. The option is stuck at "Spilt Tunnel On" with the drop-down not clickable/greyed out. I am unsure what to do from here to resolve the issue.
Regards,
Crowley
Image OpenVPN Inc.
Answers provided by OpenVPN Inc. staff members here are provided on a voluntary best-effort basis, and no rights can be claimed on the basis of answers posted in this public forum. If you wish to get official support from OpenVPN Inc. please use the official support ticket system: https://openvpn.net/support

jondlarsen
OpenVpn Newbie
Posts: 2
Joined: Sat May 14, 2022 4:34 am

Re: Unable to turn split tunnel off

Post by jondlarsen » Sat May 14, 2022 5:24 am

I am in the same boat as Christian.

I set up a network, and a group, and a connector. It works...I can connect. But Split tunneling is on. So when I am connected and lookup my public IP, it still shows the IP acquired from my provider. When I attempt to edit my network, the option changing split tunnel is greyed out. The only way to un-grey the option is to disable "Allow Internet Gateway (Egress)". This allows me to choose Split Tunnel Off...but when I do that, it says I need "Allow Internet Gateway (Egress)" enabled. It just goes round and round this way.

I understand the need to have Egress enabled. That makes sense. But then you can't turn off split tunnel. Why not???? Is this is a bug? Is there is some other settings that need configuring?

Per your suggestion, I went into groups. And I selected the default (which was my only group at that moment), and I was happy to see I could edit that. I turned off Split Tunnel. This stuck. I thought I had it figured out. The Network configuration still showed Split Tunnel on, but the group was off. So I tested and it still showed my ISP's provided IP. I even tried to create a new group and disable split tunnel with that group and it still fails. I'm at a loss. I'll take any help I can get.

Please and thank you.
~Jon

jondlarsen
OpenVpn Newbie
Posts: 2
Joined: Sat May 14, 2022 4:34 am

Re: Unable to turn split tunnel off

Post by jondlarsen » Tue May 17, 2022 3:22 am

Never mind, I went with a different solution.

afaqhabib
OpenVpn Newbie
Posts: 3
Joined: Tue Jun 21, 2022 5:03 pm

Re: Unable to turn split tunnel off

Post by afaqhabib » Tue Jun 21, 2022 5:05 pm

jondlarsen wrote:
Tue May 17, 2022 3:22 am
Never mind, I went with a different solution.

Hi, Can you share the workaround solution?
I am actually finding a solution for this as well.

Post Reply