Openvpn connection established but no tun interface created

Samples of working configurations.
Locked
ruser
OpenVpn Newbie
Posts: 2
Joined: Wed Apr 15, 2015 11:07 am

Openvpn connection established but no tun interface created

Post by ruser » Wed Apr 15, 2015 11:20 am

Hi,

The openvpn log for client shows 'Initialization Sequence Complete', but there is no tun interface seen using 'ifconfig'. Have anyone observed this behaviour ? Under what scenarios can we see this behaviour ?
Please help in this regard.

User avatar
maikcat
Forum Team
Posts: 4202
Joined: Wed Jan 12, 2011 9:23 am
Location: Athens,Greece
Contact:

Re: Openvpn connection established but no tun interface crea

Post by maikcat » Wed Apr 15, 2015 11:44 am

post your configs/logs please

Michael.

ruser
OpenVpn Newbie
Posts: 2
Joined: Wed Apr 15, 2015 11:07 am

Re: Openvpn connection established but no tun interface crea

Post by ruser » Wed Apr 15, 2015 12:06 pm

Below are the server and the client configurations used,

server.conf

Code: Select all

dev tun0
proto tcp
port 1194
ca ca.crt
cert server.crt
key server.key
dh dh2048.pem
management localhost 5001
script-security 2
server 10.8.0.0 255.255.255.0
cipher AES-192-CBC
persist-key
persist-tun
reneg-sec 0
status /var/log/openvpn-status.log
verb 4
client-to-client
push "redirect-gateway def1"
#set the dns servers
push "dhcp-option DNS 10.8.0.1"
duplicate-cn
comp-lzo

client.conf

Code: Select all

dev tun
client
proto tcp
remote server 1194
ca ca.crt
cert client1.crt
key client1.key
resolv-retry infinite
persist-key
persist-tun
cipher AES-128-CBC
comp-lzo
verb 3

User avatar
maikcat
Forum Team
Posts: 4202
Joined: Wed Jan 12, 2011 9:23 am
Location: Athens,Greece
Contact:

Re: Openvpn connection established but no tun interface crea

Post by maikcat » Wed Apr 15, 2015 12:27 pm

please post your logs also,

for now you must correct your configs since they mismatch...

server

cipher AES-192-CBC

client

cipher AES-128-CBC

you MUST use the SAME cipher on both ends.

Michael.

Locked