Cannot Connect w/ OpenVPN to Offensive Sec. Labs

Samples of working configurations.
Locked
gerhardtvongoll
OpenVpn Newbie
Posts: 1
Joined: Thu Nov 20, 2014 4:39 pm

Cannot Connect w/ OpenVPN to Offensive Sec. Labs

Post by gerhardtvongoll » Thu Nov 20, 2014 5:03 pm

Hey guys,
I'm looking for help in solving a problem I'm having w/ VPN, which Offensive Security has said is somewhere on my end. Here is the output:

Thu Nov 20 17:30:52 2014 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
Thu Nov 20 17:30:52 2014 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Thu Nov 20 17:30:52 2014 LZO compression initialized
Thu Nov 20 17:30:52 2014 UDPv4 link local: [undef]
Thu Nov 20 17:30:52 2014 UDPv4 link remote: [AF_INET]0.0.0.0.:1194
Thu Nov 20 17:31:52 2014 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Thu Nov 20 17:31:52 2014 TLS Error: TLS handshake failed
Thu Nov 20 17:31:52 2014 SIGUSR1[soft,tls-error] received, process restarting
Thu Nov 20 17:31:54 2014 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
Thu Nov 20 17:31:54 2014 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Thu Nov 20 17:31:54 2014 Re-using SSL/TLS context
Thu Nov 20 17:31:54 2014 LZO compression initialized
Thu Nov 20 17:31:54 2014 UDPv4 link local: [undef]
Thu Nov 20 17:31:54 2014 UDPv4 link remote: [AF_INET]0.0.0.0:1194
^CThu Nov 20 17:31:56 2014 event_wait : Interrupted system call (code=4)
Thu Nov 20 17:31:56 2014 SIGINT[hard,] received, process exiting
root@kali:~/lab-connection#

When i use another internet connection, coffes hops, Dunkin Donuts, etc. I do not have this problem, so it has nothing to do with my firewall, which I tried disabling but to no avail. This set up is on a VM and I've tried altering from NAT to Bridged w/ no success. Again, everything works fine when I connect from a different connection and I've told my neighbor, with whom I share the wifi, to turn his router on/off to see if that'll fix it. Nothing. As far as the certificate which it requests, that is not the problem, because I wasn connecting to the labs for several weeks with no problems. This started happening when he she sent me a text of a new pin to connect to. She is now out of town, until the 25th, and Offensive Security has told me I ought to contact my ISP, which I can't do until she returns. I've google the hell out of it and every response the person with the problem had access to configure both client and server, which I obviously can't do. And again, the problem seems to be just on my part. Any help guys? I would infinitely appreciate it.

User avatar
maikcat
Forum Team
Posts: 4202
Joined: Wed Jan 12, 2011 9:23 am
Location: Athens,Greece
Contact:

Re: Cannot Connect w/ OpenVPN to Offensive Sec. Labs

Post by maikcat » Thu Nov 20, 2014 5:40 pm

tls key negotiation errors usually reveal drop packets in the way...

check if your router filters something.

you can also try to switch your setup to tcp and test it.

Michael.

Locked