No connection over cellular with IP camera connected

Need help configuring your VPN? Just post here and you'll get that help.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
Doddle12
OpenVpn Newbie
Posts: 3
Joined: Mon Apr 19, 2021 1:55 pm

No connection over cellular with IP camera connected

Post by Doddle12 » Mon Apr 19, 2021 2:07 pm

Hi guys,

I'm new to the forum, can't seem to find an answer anywhere.

I'm running Ovpn as a service so it runs on startup as the system will be running some remote IP Cameras.

The cameras are directly connected via ethernet and have dedicated IP addresses. However ovpn tries to use these to connect which will constantly fail and won't switch to use the built in cellular. If I briefly unplug the cameras then it will switch to cell and connect immediately. I can then plug them back in.

I've tried changing the interface metric for cellular so it is the second in line after TAP for ovpn.

Any idea how to get it to ignore the ethernet ports and just use the cellular connection?

Many thanks,
Sam

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 8983
Joined: Fri Jun 03, 2016 1:17 pm

Re: No connection over cellular with IP camera connected

Post by TinCanTech » Mon Apr 19, 2021 5:38 pm

In other words: How do I setup my network correctly ?

Doddle12
OpenVpn Newbie
Posts: 3
Joined: Mon Apr 19, 2021 1:55 pm

Re: No connection over cellular with IP camera connected

Post by Doddle12 » Mon Apr 19, 2021 5:54 pm

Thanks for the sarcy comment mate, really helpful.
I've followed the correct steps to set it up, I've never come across this issue before, it only seems to do it with a cellular connection.
But you clearly know what's going on so why don't you explain it....

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 8983
Joined: Fri Jun 03, 2016 1:17 pm

Re: No connection over cellular with IP camera connected

Post by TinCanTech » Mon Apr 19, 2021 6:12 pm

Openvpn works perfectly when you setup your network correctly, what has that got to do with Openvpn ?

I can teach you about networking but not for free.

If you have a leaky pipe do you pay a plumber to fix it for you or do you let your house rot away ?

Doddle12
OpenVpn Newbie
Posts: 3
Joined: Mon Apr 19, 2021 1:55 pm

Re: No connection over cellular with IP camera connected

Post by Doddle12 » Mon Apr 19, 2021 9:47 pm

Well turns out it was nothing to do with how I set up my network, its a Windows policy issue that is solved by editing parts of the registry.

I posted here as I wasn't sure and wondered if anyone else has come across the same issue and wasn't sure if it was because of ovpn or not.

Next time, don't post if your going to be sarcy, it doesn't help anyone.

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 8983
Joined: Fri Jun 03, 2016 1:17 pm

Re: No connection over cellular with IP camera connected

Post by TinCanTech » Mon Apr 19, 2021 10:07 pm

I am not sarcastic ..

I was pointing out that what-ever your problem was it had nothing to do with OpenVPN.

As you have now confirmed..

I believe in the Freedom of Speech.

You can believe what-ever notions you want to ..
but you should understand that you may not always like the answers you get.

300000
OpenVPN Expert
Posts: 510
Joined: Tue May 01, 2012 9:30 pm

Re: No connection over cellular with IP camera connected

Post by 300000 » Tue Apr 20, 2021 1:00 pm

Doddle12 wrote:
Mon Apr 19, 2021 2:07 pm
Hi guys,

I'm new to the forum, can't seem to find an answer anywhere.

I'm running Ovpn as a service so it runs on startup as the system will be running some remote IP Cameras.

The cameras are directly connected via ethernet and have dedicated IP addresses. However ovpn tries to use these to connect which will constantly fail and won't switch to use the built in cellular. If I briefly unplug the cameras then it will switch to cell and connect immediately. I can then plug them back in.

I've tried changing the interface metric for cellular so it is the second in line after TAP for ovpn.

Any idea how to get it to ignore the ethernet ports and just use the cellular connection?

Many thanks,
Sam

you need public your config and what operate system do you install openvpn so i can help you free to access your camera wherever you like .

Post Reply