Ip not assigned to the server-side interface

Need help configuring your VPN? Just post here and you'll get that help.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
j.rollandoz
OpenVpn Newbie
Posts: 3
Joined: Tue Mar 30, 2021 10:01 am

Ip not assigned to the server-side interface

Post by j.rollandoz » Tue Mar 30, 2021 10:27 am

Hi all,

i am new to openvpn and i would like to try it for eventual implementation for a company.

I've configured a routed VPN, both on the Server (windows server 2016) and on the client (windows 10) connects successfully.
The network interface on the Server does not take the IP however. OpenVPN GUI say the ip assigned is 10.5.0.1 but if i check it via "ipconfig" i get APIPA address (169.254.x.x)

Instead on the client it correctly assigned 10.5.0.6 as marked on OpenVPN GUI.

In short, from the client I do not ping 10.5.0.1 obviously. How can i solve?

Server startup log:

Code: Select all

Tue Mar 30 12:24:54 2021 ROUTE_GATEWAY 192.168.16.254/255.255.255.0 I=12 HWADDR=ec:eb:b8:5d:7b:98
Tue Mar 30 12:24:54 2021 open_tun
Tue Mar 30 12:24:54 2021 TAP-WIN32 device [OpenVPNServer] opened: \\.\Global\{B03F9BAE-FDEC-4F00-92D4-938CA7CA2941}.tap
Tue Mar 30 12:24:54 2021 TAP-Windows Driver Version 9.24 
Tue Mar 30 12:24:54 2021 Notified TAP-Windows driver to set a DHCP IP/netmask of 10.5.0.1/255.255.255.252 on interface {B03F9BAE-FDEC-4F00-92D4-938CA7CA2941} [DHCP-serv: 10.5.0.2, lease-time: 31536000]
Tue Mar 30 12:24:54 2021 Sleeping for 10 seconds...
Tue Mar 30 12:25:04 2021 Successful ARP Flush on interface [25] {B03F9BAE-FDEC-4F00-92D4-938CA7CA2941}
Tue Mar 30 12:25:04 2021 MANAGEMENT: >STATE:1617099904,ASSIGN_IP,,10.5.0.1,,,,
Tue Mar 30 12:25:04 2021 MANAGEMENT: >STATE:1617099904,ADD_ROUTES,,,,,,
Tue Mar 30 12:25:04 2021 C:\Windows\system32\route.exe ADD 10.5.0.0 MASK 255.255.255.0 10.5.0.2
Tue Mar 30 12:25:04 2021 Warning: route gateway is not reachable on any active network adapters: 10.5.0.2
Tue Mar 30 12:25:04 2021 Route addition via service failed
Tue Mar 30 12:25:04 2021 Could not determine IPv4/IPv6 protocol. Using AF_INET6
Tue Mar 30 12:25:04 2021 Socket Buffers: R=[65536->65536] S=[65536->65536]
Tue Mar 30 12:25:04 2021 setsockopt(IPV6_V6ONLY=0)
Tue Mar 30 12:25:04 2021 UDPv6 link local (bound): [AF_INET6][undef]:1194
Tue Mar 30 12:25:04 2021 UDPv6 link remote: [AF_UNSPEC]
Tue Mar 30 12:25:04 2021 MULTI: multi_init called, r=256 v=256
Tue Mar 30 12:25:04 2021 IFCONFIG POOL: base=10.5.0.4 size=62, ipv6=0
Tue Mar 30 12:25:04 2021 IFCONFIG POOL LIST
Tue Mar 30 12:25:04 2021 Initialization Sequence Completed
Tue Mar 30 12:25:04 2021 MANAGEMENT: >STATE:1617099904,CONNECTED,SUCCESS,10.5.0.1,,,,

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 8957
Joined: Fri Jun 03, 2016 1:17 pm

Re: Ip not assigned to the server-side interface

Post by TinCanTech » Tue Mar 30, 2021 11:34 am

Start Windows DHCP Client Service.

j.rollandoz
OpenVpn Newbie
Posts: 3
Joined: Tue Mar 30, 2021 10:01 am

Re: Ip not assigned to the server-side interface

Post by j.rollandoz » Tue Mar 30, 2021 12:29 pm

TinCanTech wrote:
Tue Mar 30, 2021 11:34 am
Start Windows DHCP Client Service.
SOLVED!
I've checked DHCP Client Service and was in running state. So, after a restart, OpenVPN assigned the correct IP ad i'm able to ping it from the remote client!

Another question... If i want to reach the physical interface IP of the Server, 192.168.16.251, how can i do? I have to push the route in the server config file?

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 8957
Joined: Fri Jun 03, 2016 1:17 pm

Re: Ip not assigned to the server-side interface

Post by TinCanTech » Tue Mar 30, 2021 2:18 pm

On planet Earth we start by reading the documentation.

j.rollandoz
OpenVpn Newbie
Posts: 3
Joined: Tue Mar 30, 2021 10:01 am

Re: Ip not assigned to the server-side interface

Post by j.rollandoz » Wed Mar 31, 2021 8:55 am

TinCanTech wrote:
Tue Mar 30, 2021 2:18 pm
On planet Earth we start by reading the documentation.
I have read the documentation and tried multiple ways to fix. I can only reach the Server via OpenVPN IP.


For information, about the first problem, if a i disconnect the OpenVPN Server, and i try to do a new Connect, i get APIPA address again. So i have to restart DHCP Client Service again to get the correct IP.

300000
OpenVPN Expert
Posts: 507
Joined: Tue May 01, 2012 9:30 pm

Re: Ip not assigned to the server-side interface

Post by 300000 » Tue Apr 06, 2021 10:49 pm

you can setting a static ip for your openvpn network card so it is simple and next time dont need to do anything just add this line into client and going to windows network setting and assign a ip 10.5.0.6 subnet mask should 255.255.255.0 for openvpn card . only need ip and subnet mask , you dont need gateway and dns setting and leave it blank.

ip-win32 manual

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 8957
Joined: Fri Jun 03, 2016 1:17 pm

Re: Ip not assigned to the server-side interface

Post by TinCanTech » Tue Apr 06, 2021 11:01 pm

j.rollandoz wrote:
Tue Mar 30, 2021 12:29 pm
Another question... If i want to reach the physical interface IP of the Server, 192.168.16.251, how can i do? I have to push the route in the server config file?
You read the howto again.

And then you read this:
viewtopic.php?f=30&t=22603

If you don't post the requested details then you leave us no choice ..
  • Crystal ball
  • ...
  • Ridicule
And if @man1ck doesn't like that then he/she/it can try providing Free support
to lusers that don't follow instructions, alone..

Post Reply