new user newly installed vpn on rasp pi 4 - slow browsing

Need help configuring your VPN? Just post here and you'll get that help.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
s_schwant
OpenVpn Newbie
Posts: 3
Joined: Mon Jan 04, 2021 5:43 pm

new user newly installed vpn on rasp pi 4 - slow browsing

Post by s_schwant » Mon Jan 04, 2021 5:49 pm

Hello,

Brand new to the forum and just got my vpn up and running on raspberry pi alongside pi-hole. I'm noticing that I have to frequently shut off the vpn in order to get some web pages to load. Not sure why this is ... if I do a quick disconnect or pause then resume on Android that seems to fix it, on my wired desktop I have to disconnect completely to get certain sites to load. Just curious if this is common and if there are any suggested work-arounds/fixes.

Thanks!
Steve
p.s., perhaps there's an issue with the config on the server (but seems to work fine), or maybe I need to edit settings on clients and Chrome's proxy settings?
Last edited by s_schwant on Mon Jan 04, 2021 7:09 pm, edited 1 time in total.

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 8374
Joined: Fri Jun 03, 2016 1:17 pm

Re: new user newly installed vpn on rasp pi 4 - slow browsing

Post by TinCanTech » Mon Jan 04, 2021 6:45 pm

Try reading your log files.

s_schwant
OpenVpn Newbie
Posts: 3
Joined: Mon Jan 04, 2021 5:43 pm

Re: new user newly installed vpn on rasp pi 4 - slow browsing

Post by s_schwant » Mon Jan 04, 2021 7:10 pm

Okay, will take a look at log file/s.

300000
OpenVPN Super User
Posts: 426
Joined: Tue May 01, 2012 9:30 pm

Re: new user newly installed vpn on rasp pi 4 - slow browsing

Post by 300000 » Tue Jan 05, 2021 12:47 pm

the monster pi-hole cant do the job good so you can turn it off to see how fast it is compare with turn it on. sometime block too much on pi-hole stop working all so it is nothing to do with openvpn but pi-hole is in question.

s_schwant
OpenVpn Newbie
Posts: 3
Joined: Mon Jan 04, 2021 5:43 pm

Re: new user newly installed vpn on rasp pi 4 - slow browsing

Post by s_schwant » Sat Jan 09, 2021 1:20 pm

I'll try turning pi-hole off . . . although while pi-hole might restrain some IPs/DNS's from loading intially (or maybe thats the vpn?), it doesn't seem to limit my bandwidth. Speed tests are comparable to before installing pihole (and vpn) - which was one of my main concerns.

Regarding log files ... I didn't see a log file while in pivpn in the terminal window. Though I did run the debug which dropped out a debug log. Is there some other log that is captured while the vpn is normally running? What would I be looking for in the log file that might trigger some reconfiguation or other action?

Thanks!!
Steve

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 8374
Joined: Fri Jun 03, 2016 1:17 pm

Re: new user newly installed vpn on rasp pi 4 - slow browsing

Post by TinCanTech » Sat Jan 09, 2021 3:51 pm

If you are using PiVPN and it works then your VPN is working as expected.

300000
OpenVPN Super User
Posts: 426
Joined: Tue May 01, 2012 9:30 pm

Re: new user newly installed vpn on rasp pi 4 - slow browsing

Post by 300000 » Sat Jan 09, 2021 4:08 pm

It depends on upload speed from server. What is your upload speed? You didn't say anything on that side . I have 1 gb speed and my raspberry running openvpn so on the client openvpn my speed is 80 mb that is normal .

You said that "get some web pages to load" so it depends on dns server . Now you said is slow the whole thing . It seem change now

Post Reply