[Solved] OpenVPN TCP connection drop

Need help configuring your VPN? Just post here and you'll get that help.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Locked
User avatar
ConsultationPC
OpenVpn Newbie
Posts: 4
Joined: Tue Aug 06, 2019 1:05 pm

[Solved] OpenVPN TCP connection drop

Post by ConsultationPC » Tue Aug 06, 2019 1:19 pm

Hi guys !

OpenVPN server listening on TCP 1194. Many users on it and it work flawlessly, except for one user.

- Block list verified : OK
- Tested with 2 connexion : 1 ISP and 1 iPhone, same problem.

The client try to connect and then give an "unkown error TCP 10060".
- Updated the software on the client side
- Disable the antivirus/firewall
- Verified the proxy configuration : no proxy (default), no change here

Do you have a clue about that ? The only change for this user/computer is the migration from Windows 7 to Windows 10 with the Media Creation Tool (no format).

Thank you,
Patrick

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 5873
Joined: Fri Jun 03, 2016 1:17 pm

Re: OpenVPN TCP connection drop

Post by TinCanTech » Tue Aug 06, 2019 2:53 pm


User avatar
ConsultationPC
OpenVpn Newbie
Posts: 4
Joined: Tue Aug 06, 2019 1:05 pm

Re: OpenVPN TCP connection drop

Post by ConsultationPC » Tue Aug 06, 2019 3:23 pm

Hi TinCanTech,

Already read. At this time, since all clients are working well and only one isn't able to do it since a Windows migration, it is not a server side problem. So it will not be usefull to add server configuration.

I would like to know if someone here has already see this kind of problem.

User avatar
ConsultationPC
OpenVpn Newbie
Posts: 4
Joined: Tue Aug 06, 2019 1:05 pm

Re: OpenVPN TCP connection drop

Post by ConsultationPC » Mon Aug 12, 2019 12:36 pm

Good morning guys,

Any clue about that ?

User avatar
ConsultationPC
OpenVpn Newbie
Posts: 4
Joined: Tue Aug 06, 2019 1:05 pm

Re: OpenVPN TCP connection drop

Post by ConsultationPC » Sun Aug 18, 2019 3:47 pm

Problem solved !

The HP LAN/WLAN Switch Service, who manage the dockstation connexion to switch between wifi operation and rj45 operation, was misleading the TAP driver in dispatching correctly the network traffic.

At this time, the service is disabled and we have to manually use the radio button on the laptop. Not a big problem. So: Working !

Locked