OSMC problem connecting to VPN server

Need help configuring your VPN? Just post here and you'll get that help.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
thismandan
OpenVpn Newbie
Posts: 2
Joined: Thu Apr 20, 2017 1:08 pm

OSMC problem connecting to VPN server

Post by thismandan » Thu Apr 20, 2017 1:38 pm

Hello, apologies if this is the wrong place for my question...

I'm completely new to using Linux and the terminal and I have tried to research on the internet for a solution to my problem but I have hit a brick wall and I'm at my wits end trying to make this work :cry:

I have bought a Raspberry Pi 3 model B and installed OSMC as the operating system.

After researching online I decided to use a VPN for all connections to the internet.

To confirm the Pi IP address, I navigated to My OSMC, Network, Wireless
*eg. same as terminal command (ifconfig) = wlan0 inet addr:192.168.1.100

I downloaded and installed PUTTY for windows on my laptop http://www.putty.org/ and used the Pi IP address to SSH on port 22 to get a command line on the PI

I then ran an update on the pi and installed openvpn
(sudo apt-get update)
(sudo apt-get install openvpn)

I then created a new directory /home/osmc/opnvpn and changed the permissions so that I could read write to the directory.
(sudo mkdir openvpn)
(sudo chmod a+r home/osmc/openvpn)

I have also set up and paid for a VPN provider
*expressvpn They have provided me with .ovpn .crt and .key files. for the VPN server I want to connect to.

I downloaded the PSCP.exe for windows to transfer the files using PUTTY to the openvpn folder on the Pi
*eg in PUTTY C:\temp>pscp c:\temp\ca.crt osmc@192.168.1.100:/home/osmc/openvpn

As this is my first time using a linux terminal, I opted to install the Zomboided VPN manager as this has a GUI. I got the repository from the following location https://seo-michael.co.uk/vpn-manager-f ... elec-kodi/

I transferred the .zip repository file to the Pi using PSCP

I installed installed in OSMC by navigating to Settings, Add-on Browser, Install from Zip file

I then navigated back to Settings, Add-on Browser, install from repository, Zomboided Add-on repository, services, vpn manager for open vpn, install.

In VPN configuration I selected my VPN provider expressvpn from the VPN provider list, eneterd the username and password that was provided my expressvpn.

I then navigated to VPN connections and selected First VPN connection (optionally used to auto connect during boot), I selected the server name for the VPN that I'm trying to connect to. Just to confirm the name of the server is the same as the .ovnp .crt and.key files that I have been provided with from expressvpn

I get the following error:

Error connecting to VPN, authentication failed. Check your username and password (or cert and key files).

I spoke to expressvpn customer support, but they said that they don't support the operating system I'm trying to use.

I checked online and it looks like I needed to create a .txt file with my username and password and edit the .ovpn file to reference the password.txt file, rename the .ovpn file to .conf and move this to the openvpn
(vi pass.txt)
(sudo nano pass.txt)
*entered username provided for VPN server by expressvpn on line 1
*entered password provided for VPN server by expressvpn on line 2
*pressed crt & x
*y
*enter (sudo nano .ovpn file)
*where it displayed auth-user-pass pointed to path of pass.txt file
*eg auth-user-pass /home/osmc/openvpn/pass.txt
*pressed crt & x
*y
*enter
*renamed .ovpn file to .conf sudo mv /home.osmc/openvpn/filename.ovpn
*renamed to filename.conf
*copied all files to openvpn
(sudo cp /home/osmc/openvpn/filename.conf /etc/openvpn)
(cd /etc/openvpn)
(ls) *I can see all the copied files in the /etc/openvpn directory

I then tried again to connect to the VPN server in VPN connections First VPN connection....

Error connecting to VPN, authentication failed. Check your username and password (or cert and key files).

I have double checked that I'm using the correct username and password, but I'm now lost as to what the next steps are to get the VPN working?

Is there anything else that I need to do, or am missing some steps in order to get the VPN set up correctly?

Any help would be greatly appreciated, thank you in advance

Dan

Skywalk78
OpenVpn Newbie
Posts: 1
Joined: Fri Apr 20, 2018 5:06 pm

Re: OSMC problem connecting to VPN server

Post by Skywalk78 » Fri Apr 20, 2018 5:08 pm

Hello Dan,

I have exactly the same issue with the first connexion of VPN on OSMC.

Did you solve the problem?

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 4901
Joined: Fri Jun 03, 2016 1:17 pm

Re: OSMC problem connecting to VPN server

Post by TinCanTech » Fri Apr 20, 2018 5:38 pm

Skywalk78 wrote:
Fri Apr 20, 2018 5:08 pm
I have exactly the same issue
And Zero Evidence .. :evil: (posted a year to the day ..... )

Post Reply