Site to site with OPENVPN and DSR-250n/dsr-1000ac

Need help configuring your VPN? Just post here and you'll get that help.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
leknoppix
OpenVpn Newbie
Posts: 4
Joined: Tue Mar 28, 2017 2:53 pm

Site to site with OPENVPN and DSR-250n/dsr-1000ac

Post by leknoppix » Tue Mar 28, 2017 3:26 pm

Hello all,

I come here because I have a problem.

I'm trying to connect 2 sites between dsr-250n and dsr-1000ac using OPENVPN.
My local network (site 1) is 192.168.1.X 255.255.255.0 (dsr-1000ac)
My other network (site 2) is 192.168.10.X 255.255.255.0 (dsr-250n)

I have generate the certificat with this how to: https://debian-facile.org/doc:reseau:openvpn (sorry, I'm french)

I have integrate this certificat in my dsr-1000ac (openvpn server) and my client certificat in my dsr-250n (using my primary IP of my WIN).
Image

In the dashboard, I get the impression that the VPN via OpenVPN is OK.
I have this
Image
But I can't ping from site1 to site2 and conversely.

Can you help me?

leknoppix
OpenVpn Newbie
Posts: 4
Joined: Tue Mar 28, 2017 2:53 pm

Re: Site to site with OPENVPN and DSR-250n/dsr-1000ac

Post by leknoppix » Wed Mar 29, 2017 4:27 pm

Nobody?

I think that my problem is about route static and no about openvpn

I have this

Code: Select all

Location 1 (192.168.1.X/255.255.255.0) // NET // (192.168.10.X/255.255.255.0) Location 2
Location 1 is my openvpn server 128.10.0.0/255.255.255.0
In my route stating in Location 1, I have do

Code: Select all

Name	Destination	Subnet Mask	Gateway	Interface	Metric	Active	Private
VPN_1	128.10.0.0	255.255.255.0	192.168.1.1	LAN		2	yes		no
VPN_2	192.168.10.1	255.255.255.0	192.168.1.1	LAN		2	yes		no
And in my Location 2:

Code: Select all

Name	Destination	Subnet Mask	Gateway	Interface	Metric	Active	Private
VPN_1	128.10.0.1	255.255.255.0	192.168.10.1	LAN		2	yes		no
VPN_2	192.168.1.0	255.255.255.0	192.168.10.1	LAN		2	yes		no
Someone can help me?

leknoppix
OpenVpn Newbie
Posts: 4
Joined: Tue Mar 28, 2017 2:53 pm

Re: Site to site with OPENVPN and DSR-250n/dsr-1000ac

Post by leknoppix » Wed Apr 05, 2017 12:03 pm

Hello All

no answer!!

I have this in my iptable of openvpnserver
Kernel IP routing table

Code: Select all

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.2.1     0.0.0.0         UG    0      0        0 eth1
10.8.0.0        10.8.0.2        255.255.0.0     UG    0      0        0 tun1
10.8.0.2        0.0.0.0         255.255.255.255 UH    0      0        0 tun1
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 bdg1
192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
192.168.10.0    10.8.0.2        255.255.255.0   UG    0      0        0 tun1
192.168.30.0    10.8.0.2        255.255.255.0   UG    0      0        0 tun1
192.168.90.0    10.8.0.2        255.255.255.0   UG    0      0        0 tun1
and in my openvpn client

Code: Select all

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
127.0.0.1       127.0.0.1       255.255.255.255 UGH   1      0        0 lo
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
192.168.90.0    0.0.0.0         255.255.255.0   U     0      0        0 bdg1
192.168.90.0    192.168.90.1    255.255.255.0   UG    1      0        0 bdg1
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         192.168.1.254   0.0.0.0         UG    0      0        0 eth1

I do not understand what's going on

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 8374
Joined: Fri Jun 03, 2016 1:17 pm

Re: Site to site with OPENVPN and DSR-250n/dsr-1000ac

Post by TinCanTech » Wed Apr 05, 2017 1:00 pm

First, most people using this forum do not use the same router as you, so will not be able to help.

Second, your configs do not match your route tables ..
In one post you use 128.10.0.0/24 (Which you should not use)
In another post you use 10.8.0.0/24 .. so which is it ?

I suggest you read the openvpn HOWTO completely.

leknoppix
OpenVpn Newbie
Posts: 4
Joined: Tue Mar 28, 2017 2:53 pm

Re: Site to site with OPENVPN and DSR-250n/dsr-1000ac

Post by leknoppix » Wed Apr 05, 2017 1:22 pm

I realized that the range 128.10.0.1/24 was protected; So I switch to an ip page 10.8.0.0/24
Last edited by leknoppix on Wed Apr 05, 2017 1:30 pm, edited 1 time in total.

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 8374
Joined: Fri Jun 03, 2016 1:17 pm

Re: Site to site with OPENVPN and DSR-250n/dsr-1000ac

Post by TinCanTech » Wed Apr 05, 2017 1:25 pm

leknoppix wrote:I switch to an ip page 10.0.0.0/24
No you did not .. you switched to 10.8.0.0

Please see the HOWTO above.

krychek
OpenVpn Newbie
Posts: 1
Joined: Mon Jan 11, 2021 10:47 am

Re: Site to site with OPENVPN and DSR-250n/dsr-1000ac

Post by krychek » Mon Jan 11, 2021 10:57 am

Hi!
Were you able to set up the connection after all? I want to do the same thing: site to site with OpenVPN and two DSR-250N routers.
I was following this guide: ftp://ftp2.dlink.com/PRODUCTS/DSR-SERIE ... PENVPN.pdf
Instead of certs I'm using a password for now. I didn't set up and static routes or anything else that's not in the guide.
Both router's GUI show that the OpenVPN connection is working just like it's shown in the guide. However the last step is not working, I'm not able to ping 192.168.10.1 and 192.168.20.1 from either site.
I'm really new to VPNs and don't know how to proceed.
Thanks for any help.

Post Reply