Very slow transfer speeds

Need help configuring your VPN? Just post here and you'll get that help.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
OpenVPN User
Posts: 11
Joined: Thu Nov 03, 2016 9:28 pm

Re: Very slow transfer speeds

Post by dancos » Wed Nov 09, 2016 10:54 am

Thank you for the hint, I've checked all the MTU values for server, tap devices and client (even router, but taking that out of the equation did not make any difference before). It's always 1500, changing the MTU value up/down when starting the tunnel only decreases performance.

It's hard to say whether it's only slow in one direction or whether the tunnel is just somehow stuck at 40 mbps in both directions since that's also my upload limit.

OpenVPN User
Posts: 11
Joined: Thu Nov 03, 2016 9:28 pm

Re: Very slow transfer speeds

Post by dancos » Mon Nov 14, 2016 9:04 am

Very odd... I left iperf running now with a BW report every 4 seconds. It looks like I periodically get about 100 mbps for a short time then it's back to 30-40:
[ 3] 88396.0-88400.0 sec 17.0 MBytes 35.7 Mbits/sec
[ 3] 88400.0-88404.0 sec 19.1 MBytes 40.1 Mbits/sec
[ 3] 88404.0-88408.0 sec 49.9 MBytes 105 Mbits/sec
[ 3] 88408.0-88412.0 sec 41.1 MBytes 86.2 Mbits/sec
[ 3] 88412.0-88416.0 sec 20.9 MBytes 43.8 Mbits/sec
... more entries ...
[ 3] 88640.0-88644.0 sec 32.8 MBytes 68.7 Mbits/sec
[ 3] 88644.0-88648.0 sec 17.9 MBytes 37.5 Mbits/sec
[ 3] 88648.0-88652.0 sec 22.8 MBytes 47.7 Mbits/sec
[ 3] 88652.0-88656.0 sec 22.4 MBytes 46.9 Mbits/sec
[ 3] 88656.0-88660.0 sec 26.6 MBytes 55.8 Mbits/sec
[ 3] 88660.0-88664.0 sec 54.5 MBytes 114 Mbits/sec
[ 3] 88664.0-88668.0 sec 17.4 MBytes 36.4 Mbits/sec
[ 3] 88668.0-88672.0 sec 17.8 MBytes 37.2 Mbits/sec
[ 3] 88672.0-88676.0 sec 20.8 MBytes 43.5 Mbits/sec
Does anyone know what could explain such variance?

OpenVpn Newbie
Posts: 1
Joined: Thu Dec 22, 2016 5:27 am

Re: Very slow transfer speeds

Post by KaszasT » Thu Dec 22, 2016 5:30 am


We have the exact same situation, with worse speeds (iperf 80, 80, 60,40, 20, 0, 0, 0, 20, 60, 80, 40, 0 ,0, etc.). I walked down the same path, nothing helped. Do you got any solution for this problem?


OpenVpn Newbie
Posts: 1
Joined: Thu Feb 23, 2017 7:35 am

Re: Very slow transfer speeds

Post by ludwig.gramberg » Thu Feb 23, 2017 7:56 am

having the same problem here, speeds just make no sense

the scenario (all values in mbit down/up):

Code: Select all

client A <---200/10---> vpn-server(100/100) <---300/30---> client B
when client A downloads from client B the speed is limited at precisely 10mbit (avg 9,8)
but that direction should allow for 30mbit since thats the limit here.
then when client B pushed some files to the vpn-server the limit was 20mbit.
doing any up/download outside the realm of openvpn the actual speeds are achieved.

client A and B can easily compute the aes so this should not be the limiting factor, also why does client A not reach at least the 20mbit client B did get? just makes no sense...

I tried the settings which were recommended on the wiki but it did not help.
any advice? also played around with different mtu etc.


Code: Select all

port 1196
proto tcp
dev tun2
ca ca-*****.crt
cert *****.crt
key ****.key  # This file should be kept secret
dh dh2048-****.pem
ifconfig-pool-persist ipp-****.txt
client-config-dir /etc/openvpn/ccd/****
keepalive 10 120
cipher AES-256-CBC
comp-lzo no
user nobody
group nogroup
status openvpn-status-*****.log
log-append /var/log/openvpn-*******.log

# 0 is silent, except for fatal errors
# 4 is reasonable for general usage
# 5 and 6 can help to debug connection problems
# 9 is extremely verbose
verb 4
mute 10

Code: Select all

remote ***** 1196 tcp-client
ca /etc/openvpn/*****/ca.crt
dev tun
cert /etc/openvpn/*****/*****.crt
comp-lzo no
key /etc/openvpn/*****/*****.key
cipher AES-256-CBC

User avatar
OpenVPN Protagonist
Posts: 4184
Joined: Fri Jun 03, 2016 1:17 pm

Re: Very slow transfer speeds

Post by TinCanTech » Thu Feb 23, 2017 11:59 am

ludwig.gramberg wrote:speeds just make no sense
ludwig.gramberg wrote:proto tcp

OpenVpn Newbie
Posts: 3
Joined: Wed Feb 08, 2017 11:02 am

Re: Very slow transfer speeds

Post by kolargol » Thu Aug 31, 2017 10:00 am

was this issue ever resolved. I have same issues with OpenVPN 2.4.1

OpenVPN User
Posts: 11
Joined: Thu Nov 03, 2016 9:28 pm

Re: Very slow transfer speeds

Post by dancos » Thu Sep 07, 2017 6:19 am

No, we haven't been able to solve this and had to abandon OpenVPN unfortunately. We've tried every transfer speed improvement suggestion out there and experimented with a myriad of different configurations but never came close to the line speeds.

OpenVPN User
Posts: 23
Joined: Tue May 01, 2012 9:30 pm

Re: Very slow transfer speeds

Post by 300000 » Thu Sep 07, 2017 11:25 am

you can try adding this on your server config to see if the speed can max or not
sndbuf 3399999
rcvbuf 3399999
push "sndbuf 3399999 "
push "rcvbuf 3399999 "

my server run over 6 months without restart and client can connect at full speed up and down and i am happy , hope it can help your speed trouble.

OpenVpn Newbie
Posts: 1
Joined: Thu Feb 01, 2018 1:47 pm

Re: Very slow transfer speeds

Post by ejanszen » Thu Feb 01, 2018 1:56 pm

The answer is easy: You cannot connect with a higher speed than your lowest upload speed.

For instance, if you have like me on the server side a download speed of 75Mb and an upload speed of 8Mb and on the client side a download speed of 30Mb with an upload speed of 4Mb. It is only then logical that the max speed of the VPN connect is 4Mb.

In this example the speed of the VPN connection can only be increased by increasing the upload speed on the client side.

OpenVpn Newbie
Posts: 3
Joined: Fri Dec 08, 2017 1:25 pm

Re: Very slow transfer speeds

Post by kosta88 » Fri May 04, 2018 9:06 am

I have the same miserable problem. My upload at home is 12mBit, download at work is at least 50mBit, and yet, I get speeds way below 1mBit.

However, the problem seems to exist when I transfer more smaller files. If I attempt to transfer single bigger file back and forth, seems to work quite well.

We use Sophos Firewall, I will question there, but I see I am not the only one with the problem... any ideas what/how to troubleshoot?

Post Reply