Help! OpenVPN Clint Slow on Windows, Fast on Linux

Need help configuring your VPN? Just post here and you'll get that help.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
reeco
OpenVpn Newbie
Posts: 15
Joined: Tue May 21, 2013 5:36 pm

Help! OpenVPN Clint Slow on Windows, Fast on Linux

Post by reeco » Fri Feb 21, 2014 1:17 pm

I'm using the same client.conf on a Ubuntu desktop, Window 7 32 bit, Windows 7 64 bit, and WinXP. All from the same cable connection.

On the Ubuntu machine, speedtest.net averages 10MB down. With Win7 it's about 2-3MB down (regardless of windows version). On XP I'm lucky to get 0.5MB down.

Without the VPN connection, all OS version run at about 25MB down.

What could cause this?

Here's my client.conf

Code: Select all

client
dev tun
proto udp
remote xxx.x.xx.xx 1194
resolv-retry infinite
nobind
persist-key
persist-tun
comp-lzo
verb 3
remote-cert-tls server

<ca>
-----BEGIN CERTIFICATE-----

-----END CERTIFICATE-----
</ca>
<cert>
-----BEGIN CERTIFICATE-----

-----END CERTIFICATE-----
</cert>
<key>
-----BEGIN PRIVATE KEY-----

-----END PRIVATE KEY-----
</key>

reeco
OpenVpn Newbie
Posts: 15
Joined: Tue May 21, 2013 5:36 pm

Re: Help! OpenVPN Clint Slow on Windows, Fast on Linux

Post by reeco » Fri Feb 21, 2014 3:32 pm

Version on the server is: openvpn-2.2.2-1.el6.rf.i686

reeco
OpenVpn Newbie
Posts: 15
Joined: Tue May 21, 2013 5:36 pm

Re: Help! OpenVPN Clint Slow on Windows, Fast on Linux

Post by reeco » Sat Feb 22, 2014 2:49 am

I tried changing to TCP with no improvement. I then ran some ping tests to find the optimal MTU which was 1400 in WinXP. So changed the TAP adapter settings to 1400 and disabled the firewall on this adapter. I then added this line to the client and server conf, and restarted openvpn.

Code: Select all

fragment 1400
mssfix
Unfortunately that has not made any improvement. I'm still getting about 0.5mb download speeds on WinXP and greater than 10MB with the same connection on a linux machine.

Any suggestions on other things to test?

reeco
OpenVpn Newbie
Posts: 15
Joined: Tue May 21, 2013 5:36 pm

Re: Help! OpenVPN Clint Slow on Windows, Fast on Linux

Post by reeco » Sat Feb 22, 2014 1:20 pm

It might be a hardware issue. I'm noticing that when running the speedtest, if I open a new tab in the browser and am viewing the new tab, the connection speed burst up to 10MB. As soon as I go back to the tab running the speedtest, the speed drops back down after about 2 seconds.

Wonder what the issue could be here?

reeco
OpenVpn Newbie
Posts: 15
Joined: Tue May 21, 2013 5:36 pm

Re: Help! OpenVPN Clint Slow on Windows, Fast on Linux

Post by reeco » Sat Feb 22, 2014 2:50 pm

Ran out of time to edit the above... but wanted to clairfy that this issue is only when I'm connected to OpenVPN. Otherwise speedtest.net shows good speeds, regardless if there is a new tab open or not.

Laakkus
OpenVpn Newbie
Posts: 11
Joined: Thu Jan 30, 2014 12:24 pm

Re: Help! OpenVPN Clint Slow on Windows, Fast on Linux

Post by Laakkus » Sun Feb 23, 2014 9:13 pm

I have the same. Seems it might be a tap-driver issue

Lähetetty minun GT-I9300 laitteesta Tapatalkilla

ogghi
OpenVpn Newbie
Posts: 3
Joined: Fri Jan 18, 2019 11:52 am

Re: Help! OpenVPN Clint Slow on Windows, Fast on Linux

Post by ogghi » Fri May 29, 2020 7:29 am

Hi there, I don't like to resurrect such an old thread, but I am experiencing the exact same problem.
PFsense with latest OpenVPN 2.4.9.
UDP server.
Linux machine gets full speed of the line, whereas Windows is always limited to around ~50Mbit/s.

Has there been any solution in the meanwhile?

lynspyre
OpenVpn Newbie
Posts: 5
Joined: Thu Jun 04, 2020 5:25 pm

Re: Help! OpenVPN Clint Slow on Windows, Fast on Linux

Post by lynspyre » Mon Jun 29, 2020 3:39 am

Check this old post, it helped me, hope it help you too.

Post Reply