403 error

Need help configuring your VPN? Just post here and you'll get that help.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
abi
OpenVpn Newbie
Posts: 1
Joined: Thu Jun 06, 2013 7:46 am

403 error

Post by abi » Thu Jun 06, 2013 7:52 am

A beg u brother to help me and sent me the solution to my mail box. The open vpn error log is given below

Wed Jun 05 22:20:26 2013 OpenVPN 2.2.2-ost-20120111 i686-pc-mingw32 [SSL] [LZO2] [PKCS11] built on Jan 11 2012
Wed Jun 05 22:20:26 2013 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Wed Jun 05 22:20:27 2013 LZO compression initialized
Wed Jun 05 22:20:27 2013 Control Channel MTU parms [ L:1560 D:140 EF:40 EB:0 ET:0 EL:0 ]
Wed Jun 05 22:20:27 2013 Socket Buffers: R=[8192->8192] S=[8192->8192]
Wed Jun 05 22:20:27 2013 Data Channel MTU parms [ L:1560 D:1450 EF:60 EB:135 ET:0 EL:0 AF:3/1 ]
Wed Jun 05 22:20:27 2013 Local Options hash (VER=V4): '958c5492'
Wed Jun 05 22:20:27 2013 Expected Remote Options hash (VER=V4): '79ef4284'
Wed Jun 05 22:20:27 2013 Attempting to establish TCP connection with 100.1.200.99:8080
Wed Jun 05 22:20:27 2013 TCP connection established with 100.1.200.99:8080
Wed Jun 05 22:20:27 2013 Send to HTTP proxy: 'CONNECT 108.61.81.139:80 HTTP/1.0'
Wed Jun 05 22:20:27 2013 HTTP proxy returned: 'HTTP/1.1 500 Internal Server Error'
Wed Jun 05 22:20:27 2013 HTTP proxy returned bad status
Wed Jun 05 22:20:27 2013 TCP/UDP: Closing socket
Wed Jun 05 22:20:27 2013 SIGTERM[soft,init_instance] received, process exiting




This is the one error log. After trying to connect many times i got an another error log shown below

Tue Jun 04 15:07:26 2013 OpenVPN 2.2.2-ost-20120111 i686-pc-mingw32 [SSL] [LZO2] [PKCS11] built on Jan 11 2012
Tue Jun 04 15:07:26 2013 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Tue Jun 04 15:07:26 2013 LZO compression initialized
Tue Jun 04 15:07:26 2013 Control Channel MTU parms [ L:1592 D:140 EF:40 EB:0 ET:0 EL:0 ]
Tue Jun 04 15:07:26 2013 Socket Buffers: R=[8192->8192] S=[8192->8192]
Tue Jun 04 15:07:26 2013 Data Channel MTU parms [ L:1592 D:1450 EF:60 EB:135 ET:32 EL:0 AF:3/1 ]
Tue Jun 04 15:07:26 2013 Local Options hash (VER=V4): 'ccabaa27'
Tue Jun 04 15:07:26 2013 Expected Remote Options hash (VER=V4): 'f99d75e1'
Tue Jun 04 15:07:26 2013 Attempting to establish TCP connection with 100.1.200.99:8080
Tue Jun 04 15:07:26 2013 TCP connection established with 100.1.200.99:8080
Tue Jun 04 15:07:26 2013 Send to HTTP proxy: 'CONNECT 108.61.81.139:443 HTTP/1.0'
Tue Jun 04 15:07:26 2013 HTTP proxy returned: 'HTTP/1.1 403 Forbidden'
Tue Jun 04 15:07:26 2013 HTTP proxy returned bad status
Tue Jun 04 15:07:26 2013 TCP/UDP: Closing socket
Tue Jun 04 15:07:26 2013 SIGTERM[soft,init_instance] received, process exiting


i have uploaded the config. files along with this....



only this user agent can make connect to this proxy:Mozilla/5.0 (BlackBerry; U; BlackBerry 9900; id) AppleWebKit/534.11+ (KHTML, like Gecko) Version/7.1.0.346 Mobile Safari/534.11+


Because, now i use user agent this in my browser it work well. This acess point is for blackberry mobiles . So we have to generate a request senten from like a blackberry handset..
So pls help me sir.I am waiting for replay

Yours faithfully,
Adiraj

attachment:http://support.openvpn.net/index.php?_m ... entid=4401

User avatar
janjust
Forum Team
Posts: 2703
Joined: Fri Aug 20, 2010 2:57 pm
Location: Amsterdam
Contact:

Re: 403 error

Post by janjust » Thu Jun 06, 2013 1:26 pm

read the manual page and look for "http-proxy-option", e.g.

Code: Select all

http-proxy-option AGENT "Mozilla/5.0 (BlackBerry; U; BlackBerry 9900; id) AppleWebKit/534.11+ (KHTML, like Gecko) Version/7.1.0.346 Mobile Safari/534.11+"
Last edited by janjust on Fri Jun 07, 2013 9:37 am, edited 1 time in total.
Reason: PS removed all crossposts; don't scream for help

Post Reply