VPN server is starting and after one minute is turning off

Need help configuring your VPN? Just post here and you'll get that help.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
Roman99
OpenVpn Newbie
Posts: 2
Joined: Tue Mar 13, 2018 3:50 pm

VPN server is starting and after one minute is turning off

Post by Roman99 » Tue Mar 13, 2018 4:06 pm

Hello,

System: CentOS 7 x86_64 (VPS -->OpenVZ)

I have strange issue connected with my VPN server. I was able to configure it according to one of the VPN tutorial and after typing 'systemctl start openvpn@server.service' it starts (Status: Active (running)) but after one minute it turns off and when I am checking the openvpn logs there is something like this:
Log Messages

Tue Mar 13 16:34:39 2018 OpenVPN 2.4.4 x86_64-redhat-linux-gnu [Fedora EPEL patched] [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Sep 26 2017
Tue Mar 13 16:34:39 2018 library versions: OpenSSL 1.0.2k-fips 26 Jan 2017, LZO 2.06
Tue Mar 13 16:34:39 2018 Diffie-Hellman initialized with 2048 bit key
Timed out
Tue Mar 13 16:36:09 2018 ERROR: Failed retrieving username or password
Tue Mar 13 16:36:09 2018 Exiting due to fatal error


Here is my server config:
Server Config

port 1194
proto udp
dev tun
ca ca.crt
cert server.crt
key server.key
dh dh.pem
server 10.8.0.0 255.255.255.0
ifconfig-pool-persist ipp.txt
push "redirect-gateway def1 bypass-dhcp"
push "dhcp-option DNS 8.8.8.8"
push "dhcp-option DNS 8.8.4.4"
keepalive 10 120
cipher AES-256-CBC
user nobody
group nobody
persist-key
persist-tun
status openvpn-status.log
log openvpn.log
verb 3
explicit-exit-notify 1


Thank you so much for your help.
Cheers!

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 4804
Joined: Fri Jun 03, 2016 1:17 pm

Re: VPN server is starting and after one minute is turning off

Post by TinCanTech » Tue Mar 13, 2018 8:19 pm

See --askpass in The Manual v24x

Roman99
OpenVpn Newbie
Posts: 2
Joined: Tue Mar 13, 2018 3:50 pm

Re: VPN server is starting and after one minute is turning off

Post by Roman99 » Wed Mar 14, 2018 9:44 am

TinCanTech wrote:
Tue Mar 13, 2018 8:19 pm
See --askpass in The Manual v24x
It works! Thank you!
Have a great day!

Post Reply