can't see server machine after running bridge start script

This forum is for all inquiries relating to the installation of OpenVPN from source and with binaries.
Forum rules
Please visit (and READ) the OpenVPN HowTo http://openvpn.net/howto prior to asking any questions in here!
Post Reply
clecol
OpenVpn Newbie
Posts: 1
Joined: Wed Aug 18, 2010 8:09 pm

can't see server machine after running bridge start script

Post by clecol » Wed Aug 18, 2010 8:16 pm

Hey all,
I'm trying to get a Ubuntu 10.04 openvpn server up and running. My server is behind a router where it has a fixed IP address of 192.168.66.112. The router has been configured to port forward ports 22 (for ssh) and 1194 (vpn) through to that address. When the machine boots up normally, I can ssh into the machine from the outside world and everything is good until I run the bridge_start script modified from here http://openvpn.net/index.php/open-sourc ... dging.html:

Code: Select all

#!/bin/bash
br="br0"
tap="tap0"
eth="eth0"
eth_ip="192.168.66.112"
eth_netmask="255.255.255.0"
eth_broadcast="192.168.66.1"

for t in $tap; do
    openvpn --mktun --dev $t
done

brctl addbr $br
brctl addif $br $eth

for t in $tap; do
    brctl addif $br $t
done

for t in $tap; do
    ifconfig $t 0.0.0.0 promisc up
done

ifconfig $eth 0.0.0.0 promisc up

ifconfig $br $eth_ip netmask $eth_netmask broadcast $eth_broadcast
When I run that script, I can't ssh into the server anymore...but I can't seem to get the iptables correct as to allow traffic to flow through as intended :( Any gurus out there have any advice?

User avatar
krzee
Forum Team
Posts: 729
Joined: Fri Aug 29, 2008 5:42 pm

Re: can't see server machine after running bridge start scri

Post by krzee » Mon Aug 23, 2010 7:52 am

does the machine still have a gateway when you run your script? it could be as simple as adding a line to the script to re-add your gateway.

Post Reply