Problem with TAP-Driver in 2.1.2 on Win7 x64 [solved]

This forum is for all inquiries relating to the installation of OpenVPN from source and with binaries.
Forum rules
Please visit (and READ) the OpenVPN HowTo http://openvpn.net/howto prior to asking any questions in here!
Post Reply
Intruder73
OpenVpn Newbie
Posts: 4
Joined: Tue Aug 17, 2010 7:11 am

Problem with TAP-Driver in 2.1.2 on Win7 x64 [solved]

Post by Intruder73 » Tue Aug 17, 2010 12:59 pm

Hi,

yesterday i tried to install Version 2.1.2 on some Win7-x64 PCs.
After Installation i am getting the following message in "TAP-Win32 Adapter V9" in the Device Manager:

Code: Select all

Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)
It is not possible to establish a connection because of "all Adapters being in use".

Can someone confirm that Problem o am i doing something completely wrong?

reverting to 2.1.1 works fine.

Thanks for your answers

Intruder73
Last edited by Intruder73 on Mon Aug 30, 2010 9:08 am, edited 1 time in total.

ekenchan
OpenVpn Newbie
Posts: 2
Joined: Tue Aug 17, 2010 2:15 pm

Re: Problem with TAP-Driver in 2.1.2 on Win7 x64

Post by ekenchan » Wed Aug 18, 2010 3:30 am

I got the same issue on win 7 pro x64, too

I have to disable the driver signature enforcement temporarily.

swautier
OpenVpn Newbie
Posts: 6
Joined: Mon Aug 16, 2010 4:30 pm

Re: Problem with TAP-Driver in 2.1.2 on Win7 x64

Post by swautier » Wed Aug 18, 2010 6:54 am

intruder73, in case you didn't see my answer to your suggestion in my post about W2008:
Yes, your suggestion to revert to 2.1.1 solved the problem.

Cheers,

Serge.

User avatar
ecrist
Forum Team
Posts: 254
Joined: Wed Nov 26, 2008 10:33 pm
Location: Minneapolis, MN
Contact:

Re: Problem with TAP-Driver in 2.1.2 on Win7 x64

Post by ecrist » Wed Aug 18, 2010 11:55 am

swautier wrote:intruder73, in case you didn't see my answer to your suggestion in my post about W2008:
Yes, your suggestion to revert to 2.1.1 solved the problem.

Cheers,

Serge.
Serge,

Do you think you could post a ticket to Trac describing this issue so that it may be resolved?
OpenVPN Community Administrator
IRC: #openvpn, #openvpn-devel Twitter: @ecrist
Co-Author of Mastering OpenVPN
Author of Troubleshooting OpenVPN

Intruder73
OpenVpn Newbie
Posts: 4
Joined: Tue Aug 17, 2010 7:11 am

Re: Problem with TAP-Driver in 2.1.2 on Win7 x64

Post by Intruder73 » Mon Aug 23, 2010 9:24 am

ecrist wrote:Do you think you could post a ticket to Trac describing this issue so that it may be resolved?
I posted a ticket to Trac (Ticket #45).
I had to choose 2.1.0/2.1.1, because there is no 2.1.2.

Intruder73
OpenVpn Newbie
Posts: 4
Joined: Tue Aug 17, 2010 7:11 am

Re: Problem with TAP-Driver in 2.1.2 on Win7 x64

Post by Intruder73 » Mon Aug 30, 2010 9:06 am

Works fine with 2.1.3 now :)

Thanks

Post Reply