TAP-win32 driver install problems on Vista x64

This forum is for all inquiries relating to the installation of OpenVPN from source and with binaries.
Forum rules
Please visit (and READ) the OpenVPN HowTo http://openvpn.net/howto prior to asking any questions in here!
Post Reply
neo314
OpenVpn Newbie
Posts: 8
Joined: Tue Aug 18, 2009 7:48 pm

TAP-win32 driver install problems on Vista x64

Post by neo314 » Tue Aug 18, 2009 7:56 pm

I have openVPN running without any problems on a Vista x64 Home Premium install, but when I try to install it on a Vista x64 Ultimate machine (with two NIC's if that matters) with driver signing off and UAC off, the tap driver does not install.

I have tried several things including running the installer separately, using the add tap device option, and using add hardware and browsing to the driver.

The error I get is:

The following hardware was not installed:
TAP-Win32 Adapter V9
An error occurred during the installation of the device.
Insufficient system resources exist to complete the requested service.

I have tried rebooting and minimizing resources in use (which I think has nothing to do with this).
I believe I had openVPN running on this machine before. I have tried RC15 and RC19 of 2.1 with no success. Any help would be appreciated.

Douglas
Forum Team
Posts: 297
Joined: Wed Aug 27, 2008 2:41 am

Re: TAP-win32 driver install problems on Vista x64

Post by Douglas » Wed Aug 19, 2009 1:13 pm

What version of OpenVPN are you using?

neo314
OpenVpn Newbie
Posts: 8
Joined: Tue Aug 18, 2009 7:48 pm

Re: TAP-win32 driver install problems on Vista x64

Post by neo314 » Wed Aug 19, 2009 8:05 pm

2.1 RC19. I tried RC15 first.

KaaK454
OpenVpn Newbie
Posts: 2
Joined: Mon Aug 24, 2009 6:27 pm

Re: TAP-win32 driver install problems on Vista x64

Post by KaaK454 » Mon Aug 24, 2009 6:34 pm

I have been having very similar problems with both Vista and 7 (32bit, and 64but)

The driver simply fails to install, I have even tried to manually install using devcon as follows.

"devcon.exe install <path to OemWin2k.inf> TAP0901"

This manual attempt fails also -with little information on why.

Any ideas on what is going wrong would be fantastic, I have yet to successfully install the Windows OpenVPN client between 5 different Windows Vista and Windows 7 computers (both 32bit and 64bit). I have tried EVER 2.1 RC version available with no luck.

Works great from Windows XP, but this helps me very little.

User avatar
ecrist
Forum Team
Posts: 233
Joined: Wed Nov 26, 2008 10:33 pm
Location: Minneapolis, MN
Contact:

Re: TAP-win32 driver install problems on Vista x64

Post by ecrist » Tue Aug 25, 2009 1:32 pm

Many people have used OpenVPN with the Tun/Tap adaptor within Windows Vista and Windows 7, both 32 and 64 bit. You must use the 2.1rc-19 (or later) versions to get the proper driver.

If you cannot get this working, it is likely a configuration or installation error on the part of your admin.
OpenVPN Community Administrator
IRC: #openvpn, #openvpn-devel Twitter: @ecrist
Co-Author of Mastering OpenVPN
Author of Troubleshooting OpenVPN

KaaK454
OpenVpn Newbie
Posts: 2
Joined: Mon Aug 24, 2009 6:27 pm

Re: TAP-win32 driver install problems on Vista x64

Post by KaaK454 » Tue Aug 25, 2009 8:04 pm

To be clear, there are no configuration problems. I am the admin and I run this server for private family use. My configurations (both client and server) work just fine for Windows XP, Mac OSX, and various Linux distros.

My problem is with Windows Vista and Windows 7. Any attempts to install OpenVPN_2.1_RCx fail when the installer attempts to install the virtual TAP adapter. Consequentially, the OpenVPN client is unable to connect to the server as it has no device to do so with.

I do not argue that many people run OpenVPN successfully on Windows Vista/Windows 7 --I agree with this. However, all this does for me is make my situation all the more frustrating, as I have had this identical problem of the OpenVPN installer failing to successfully add the virtual TAP adapter across multiple machines, all of which run Vista/7.

Here is an explicit example using Windows 7 x64.

1) I obtain the latest OpenVPN installer from this location.

http://openvpn.net/release/openvpn-2.1_rc19-install.exe

2) Set the installer properties to run as administrator, in Vista compatibility mode

Image

3) Making sure any previous versions of OpenVPN are uninstalled, I run the installer.

Image

4) A pop-up error informs me that the TAP adapter has failed to install

Image

5) Installer finishes installing remaining files.

Any suggestions on why the driver fails to install would be greatly appreciated; however, please do not reply with suggestions that my configuration or installation is incorrect, this is simply not the case. As stated above, I have plenty of Windows XP, Mac OSX and Linux clients on my VPN that work and communicate exactly as intended.

Thank you

neo314
OpenVpn Newbie
Posts: 8
Joined: Tue Aug 18, 2009 7:48 pm

Re: TAP-win32 driver install problems on Vista x64

Post by neo314 » Tue Aug 25, 2009 9:10 pm

ecrist wrote:Many people have used OpenVPN with the Tun/Tap adaptor within Windows Vista and Windows 7, both 32 and 64 bit. You must use the 2.1rc-19 (or later) versions to get the proper driver.

If you cannot get this working, it is likely a configuration or installation error on the part of your admin.
Can you offer any helpful advice on overcoming this problem?

I have it installed on Vista x64 Home Premium, but not on x64 ultimate. Both machines had earlier version of openVPN installed successfully. I am the administrator, and I am using 2.1rc-19 now.

I am trying to figure out why the driver will not install.

arend
OpenVpn Newbie
Posts: 1
Joined: Wed Aug 26, 2009 2:01 pm

Re: TAP-win32 driver install problems on Vista x64

Post by arend » Wed Aug 26, 2009 2:17 pm

I just installed OpenVPN 2.1 RC19 on Windows 7 RTM x64 without installation problems.
What version of Windows 7 are you using ?

Maybe a long shot, but I did opt for always trusting OpenVPN during the installation.
Could that be a reason for the tap driver install to fail ? (If you don't select that option)

neo314
OpenVpn Newbie
Posts: 8
Joined: Tue Aug 18, 2009 7:48 pm

Re: TAP-win32 driver install problems on Vista x64

Post by neo314 » Fri Aug 28, 2009 11:58 pm

I'm using Vista and that definitely is not my problem. I am getting file not found. I suspect it is related to having V8 on the computer previously but I'm not sure what to do.

kindzadza
OpenVpn Newbie
Posts: 1
Joined: Tue Oct 20, 2009 2:53 am

Re: TAP-win32 driver install problems on Windows 7 64

Post by kindzadza » Tue Oct 20, 2009 3:09 am

I have 6.1 ( Build 7600 ) and thanks for edvice :shock: i isntall http://openvpn.net/release/openvpn-2.1_rc19-install.exe and i dont have any problem.

I have a problem with 2.0.9 GUI 1.0.3 Now it's ok thanks frome MACEDONIA

neo314
OpenVpn Newbie
Posts: 8
Joined: Tue Aug 18, 2009 7:48 pm

Re: TAP-win32 driver install problems on Vista x64

Post by neo314 » Wed Oct 21, 2009 5:56 pm

I found my problem to be BitDefender. No amount of exceptions, disabling, even killing the NDIS Filters allowed the install. When I upgraded to version 2010 though, I installed open VPN after uninstalling 2009 and before installing 2010 and it worked fine. I then installed 2010 and OpenVPN is still working without a hitch.

mcatchan
OpenVpn Newbie
Posts: 2
Joined: Sat Jan 30, 2010 4:31 am

Re: TAP-win32 driver install problems on Vista x64

Post by mcatchan » Sat Jan 30, 2010 4:49 am

I'm having a problem installing the tap driver on a 32 bit version of vista, my user account control is off, i'm still running it with right click execute as admin, I tried tons of different versions of Open VPN and I always get error message when installing tap driver, it gets to the point where it shows TAP UPDATE then fails miserably. I've even disabled the antivirus, and I've searched all over the place for an answer, but nobody seems to actually give one, so does anyone actually know how to fix this?

I've read so many different "solutions" none of which have worked so far, and none of which were too clear anyhow, one guy says to install the driver manually but doesn't explain how you do that, can anyone enlighten me as to how I may do that :?:

Douglas
Forum Team
Posts: 297
Joined: Wed Aug 27, 2008 2:41 am

Re: TAP-win32 driver install problems on Vista x64

Post by Douglas » Sun Jan 31, 2010 2:26 pm

mcatchan wrote:I'm having a problem installing the tap driver on a 32 bit version of vista, my user account control is off, i'm still running it with right click execute as admin, I tried tons of different versions of Open VPN and I always get error message when installing tap driver, it gets to the point where it shows TAP UPDATE then fails miserably. I've even disabled the antivirus, and I've searched all over the place for an answer, but nobody seems to actually give one, so does anyone actually know how to fix this?

I've read so many different "solutions" none of which have worked so far, and none of which were too clear anyhow, one guy says to install the driver manually but doesn't explain how you do that, can anyone enlighten me as to how I may do that :?:
What version are you rocking?

neo314
OpenVpn Newbie
Posts: 8
Joined: Tue Aug 18, 2009 7:48 pm

Re: TAP-win32 driver install problems on Vista x64

Post by neo314 » Sun Jan 31, 2010 5:14 pm

What anti-virus firewall combo are you using. For me, all the disabling in the world made no difference, but when I uninstalled Bitdefender, TAP installed just fine and then I reinstalled Bitdefender.

mcatchan
OpenVpn Newbie
Posts: 2
Joined: Sat Jan 30, 2010 4:31 am

Re: TAP-win32 driver install problems on Vista x64

Post by mcatchan » Fri Feb 05, 2010 10:03 pm

I have windows vista fam ed premium, service pack 2, I do have mc afee normally but it's not installed atm so just avast. I haven't tried installing with it uninstalled but i have tried disabling everything. As for firewall I just have the windows one.

neo314
OpenVpn Newbie
Posts: 8
Joined: Tue Aug 18, 2009 7:48 pm

Re: TAP-win32 driver install problems on Vista x64

Post by neo314 » Sat Feb 06, 2010 7:48 pm

Dude, try uninstalling avast.
mcatchan wrote:I have windows vista fam ed premium, service pack 2, I do have mc afee normally but it's not installed atm so just avast. I haven't tried installing with it uninstalled but i have tried disabling everything. As for firewall I just have the windows one.

Cantello
OpenVpn Newbie
Posts: 1
Joined: Sun Feb 07, 2010 12:31 pm

Re: TAP-win32 driver install problems on Vista x64

Post by Cantello » Sun Feb 07, 2010 12:33 pm

neo314 wrote:Dude, try uninstalling avast.
Uninstalling Avast did not change anything. I have disabled all AV software plus have only the standard Windows firewall running.

On Win7 x64 it is exceedingly difficult to get a proper VPN connection running. OpenVPN does not install and Shrew is acting flaky, sometimes it does connect, sometimes it does not... :-/

neo314
OpenVpn Newbie
Posts: 8
Joined: Tue Aug 18, 2009 7:48 pm

Re: TAP-win32 driver install problems on Vista x64

Post by neo314 » Thu Feb 11, 2010 4:54 pm

Cantello wrote:Uninstalling Avast did not change anything. I have disabled all AV software plus have only the standard Windows firewall running.

On Win7 x64 it is exceedingly difficult to get a proper VPN connection running. OpenVPN does not install and Shrew is acting flaky, sometimes it does connect, sometimes it does not... :-/
Did you uninstall all anti-virus/firewalls or just disable them? If you left anything just disabled, uninstall it (not counting windows firewall obviously). Be sure to reboot at least once.

Also, I'm not sure about Win7, but in Vista you can F8 non startup and disable the signed driver enforcement. I would suggest trying that as well.

Good luck.

Post Reply