Installation on OmniOS

This forum is for all inquiries relating to the installation of OpenVPN from source and with binaries.
Forum rules
Please visit (and READ) the OpenVPN HowTo http://openvpn.net/howto prior to asking any questions in here!
Post Reply
petrocelli1966
OpenVpn Newbie
Posts: 16
Joined: Wed Dec 23, 2020 10:12 pm

Installation on OmniOS

Post by petrocelli1966 » Fri Dec 25, 2020 9:18 am

I installed OpenVPN on OmniOS using the joyent packages. I seem to be stuck at the tun interface. I thought the tun driver would be installed with the OpenVPN app. When I tried to enable the service, I get an error that /dev/tun cannot be found. SO I tried setting up a tun0 interface with the commands below but still no go. I still get the error. Not sure what to do. Anyone have any ideas?

# dladm create-iptun -T ipv4 -a local=192.10.0.24,remote=10.9.0.1 tun0
# ipadm create-if tun0
# ipadm create-addr -T static -a local=10.9.0.1,remote=10.9.0.2 tun0/v4

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 8374
Joined: Fri Jun 03, 2016 1:17 pm

Re: Installation on OmniOS

Post by TinCanTech » Fri Dec 25, 2020 4:22 pm

petrocelli1966 wrote:
Fri Dec 25, 2020 9:18 am
When I tried to enable the service, I get an error that /dev/tun cannot be found
That would be a packaging error by OmniOS, OpenVPN requires the tun driver.

petrocelli1966
OpenVpn Newbie
Posts: 16
Joined: Wed Dec 23, 2020 10:12 pm

Re: Installation on OmniOS[Solved]

Post by petrocelli1966 » Fri Dec 25, 2020 11:51 pm

Thanks for that response. Someone on that side assisted also. I needed to install the driver separately with pkg install pkg:/driver/tuntap

Post Reply