Tap adapters not visible in Server Rouing and Remote Access

This forum is for all inquiries relating to the installation of OpenVPN from source and with binaries.
Forum rules
Please visit (and READ) the OpenVPN HowTo http://openvpn.net/howto prior to asking any questions in here!
Post Reply
johanbar
OpenVpn Newbie
Posts: 7
Joined: Mon Dec 30, 2019 6:11 pm

Tap adapters not visible in Server Rouing and Remote Access

Post by johanbar » Mon Dec 30, 2019 6:19 pm

Hi Guys

In the latest OpenVPN 2.4.8 x86_64-w64-mingw32 the tap adapters are not visible in Windows Server 2019's Routing and Remote for Nat (also not for binding in Hyper-V).

Is this a broken driver? How can I unhide the adapter?

Thanks
Johan

johanbar
OpenVpn Newbie
Posts: 7
Joined: Mon Dec 30, 2019 6:11 pm

Re: Tap adapters not visible in Server Rouing and Remote Access

Post by johanbar » Mon Dec 30, 2019 6:29 pm

PS binding it to the Network Teaming is a workaround but silly having this for a single adapter.

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 7316
Joined: Fri Jun 03, 2016 1:17 pm

Re: Tap adapters not visible in Server Rouing and Remote Access

Post by TinCanTech » Mon Dec 30, 2019 8:24 pm

Please ensure you have installed the correct version:
  • Windows 10/Server 2016/Server 2019 installer (NSIS)
Here:
https://openvpn.net/community-downloads/

Let us know the results.

johanbar
OpenVpn Newbie
Posts: 7
Joined: Mon Dec 30, 2019 6:11 pm

Re: Tap adapters not visible in Server Rouing and Remote Access

Post by johanbar » Mon Dec 30, 2019 8:35 pm

Def openvpn-install-2.4.8-I602-Win10.exe

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 7316
Joined: Fri Jun 03, 2016 1:17 pm

Re: Tap adapters not visible in Server Rouing and Remote Access

Post by TinCanTech » Mon Dec 30, 2019 9:20 pm

Openvpn TAP has undergone considerable developer attention recently, mainly due to getting certification from Microsoft. So the developers would like to know about issues, you should consider reporting this as a bug.

If you also have access to a Win10 machine we would appreciate if you could test an install there as well.

johanbar
OpenVpn Newbie
Posts: 7
Joined: Mon Dec 30, 2019 6:11 pm

Re: Tap adapters not visible in Server Rouing and Remote Access

Post by johanbar » Mon Dec 30, 2019 9:47 pm

Windows 10 does not have a Routing and Remote Access server role. Older versions of the tap adapter seems to work still. Honestly if the devs have not tested Win 10, no one should not be using this.

Thanks for taking the time to reply though.
Regards

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 7316
Joined: Fri Jun 03, 2016 1:17 pm

Re: Tap adapters not visible in Server Rouing and Remote Access

Post by TinCanTech » Mon Dec 30, 2019 10:21 pm

johanbar wrote:
Mon Dec 30, 2019 9:47 pm
Older versions of the tap adapter seems to work still
Good.
johanbar wrote:
Mon Dec 30, 2019 9:47 pm
Windows 10 does not have a Routing and Remote Access server role
I was asking if you could simply test the install, as a volunteer who is willing to help.
johanbar wrote:
Mon Dec 30, 2019 9:47 pm
Honestly if the devs have not tested Win 10, no one should not be using this.
Double negative aside ...

The Devs have tested extensively. Do you have any idea how vast openvpn usage is ?


https://community.openvpn.net/openvpn/wiki/GettingHelp
viewtopic.php?f=30&t=22603#p68963

johanbar
OpenVpn Newbie
Posts: 7
Joined: Mon Dec 30, 2019 6:11 pm

Re: Tap adapters not visible in Server Rouing and Remote Access

Post by johanbar » Mon Dec 30, 2019 10:28 pm

Tested on Server 2019, does not work. Maybe one problem at a time?

Thanks

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 7316
Joined: Fri Jun 03, 2016 1:17 pm

Re: Tap adapters not visible in Server Rouing and Remote Access

Post by TinCanTech » Mon Dec 30, 2019 10:47 pm

johanbar wrote:
Mon Dec 30, 2019 10:28 pm
Tested on Server 2019, does not work
One server, one install, one test ...
johanbar wrote:
Mon Dec 30, 2019 10:28 pm
Maybe one problem at a time?
Better to kill two birds with one stone .. given the opportunity.

Free open source software is supported by volunteers. You can help too ..

samuli
OpenVPN Inc.
Posts: 118
Joined: Fri Aug 13, 2010 9:05 pm

Re: Tap adapters not visible in Server Rouing and Remote Access

Post by samuli » Tue Dec 31, 2019 6:40 am

The attestation-signed (Windows 10 version) of tap-windows6 driver should work just fine on Windows Server 2016/2019. Expressions "Does not work" and "older versions work" are too imprecise to understand the actual cause. Let's start from the beginning and see where things actually break:
  • Does OpenVPN (tap-windows6) install without complaints? If so, the Windows kernel accepts the driver itself and its code signature.
  • Does the tap-windows6 device show up in device manager? Are there any signs (e.g. exclamation marks) that it or its driver might be disfunctional?
For there on proceed by checking if OpenVPN can see the tap-windows6 adapter as described in the Managing Windows tap-drivers wiki article.
--
Samuli Seppänen
Community Manager
OpenVPN Technologies, Inc

irc freenode net: mattock

johanbar
OpenVpn Newbie
Posts: 7
Joined: Mon Dec 30, 2019 6:11 pm

Re: Tap adapters not visible in Server Rouing and Remote Access

Post by johanbar » Tue Dec 31, 2019 8:04 am

Hi there

Thanks for replying. It installs fine, and connects fine, vpn comes up all ok. Also fine in the Device Manager.

The tap adapters are missing in Routing and Remote Access. Also missing from the adapters available for binding in Hyper-V. Windows does not see them here, but they are listed under network adapters and functions. In previous versions I used in server 2016 they show up here and one can use them as NAT interfaces. In the latest version 2.4.8 they do not. I've installed Win 2019 server a number of times and this is always the case. OpenVPN-connect 3.0's tap devices does list here but I cannot use it since it kills IPv6 tunnels i.e. 4to6 (by design?). It does show up as a device to bind with Network Teaming (but does not show any traffic, windows displays a rolling blue circle where the traffic is supposed to go), then I can use the teaming device under Routing and Remote to NAT.

I suspect windows server identifies this version of the tap as some special vpn adapter and not a full Ethernet adapter as before?
Has no one replicated this in the Server 2019 Routing and remote access role?

Thanks again
Johan

johanbar
OpenVpn Newbie
Posts: 7
Joined: Mon Dec 30, 2019 6:11 pm

Re: Tap adapters not visible in Server Rouing and Remote Access

Post by johanbar » Wed Jan 01, 2020 7:24 am

Hi there

I'd like it very much if someone can verify that this is a bug with TAP in Server 2019.

Until then here's a solution:
Open RegEdit.exe. Go to "HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Interfaces" where each of your network adaptors (physical or virtual) has a GUID named sub-key.

Identify which one is your network adapter (look at the IP or DHCP settings in the child key=values or configure a temporary address so you can find it). Copy or note down the GUID. (Click the GUID key then hit F2 to goto rename mode and highlight the whole key, hit CTRL+C to copy to the clipboard.)

Go to "HKLM\System\CurrentControlSet\Services\RemoteAccess\Interfaces". Add a new sub-key which is the next in sequence, for example I had 1...6 so I added "7". In is key add the following...
A DWORD32 (32bit integer) called "Enabled" set to 1.
A REG_SZ (string) called "InterfaceName" then paste your interface GUID, e.g. set to "{XXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX}".
A DWORD32 called "Stamp" set to 0.
A DWORD32 called "Type" set to 3 (LAN).
Restart RRAS, the interface will appear! Right click each protocol, e.g. IPv4, IPv6 then you can right click "General" to add a "New Interface..." and your interface will then be enabled for that protocol.

Kind regards
Johan

Post Reply