[Resolved] Windows 10 - openvpn service does not start, no errors, no log

This forum is for all inquiries relating to the installation of OpenVPN from source and with binaries.
Forum rules
Please visit (and READ) the OpenVPN HowTo http://openvpn.net/howto prior to asking any questions in here!
Locked
Alexej29
OpenVpn Newbie
Posts: 2
Joined: Thu Apr 25, 2019 10:01 am

[Resolved] Windows 10 - openvpn service does not start, no errors, no log

Post by Alexej29 » Thu Apr 25, 2019 10:18 am

Hi,

long story made short: my freshly-installed OpenVPN server 2.4.7 on Windows 10 (latest updates applied) refuses to start as a service. The same damn thing is however perfectly fine if started from the OpenVPN GUI, and this is really bothering me.

What I have done so far:
  • started from a Win10 clean installation
  • applied latest Win10 updates
  • installed OpenVPN 2.4.7
  • migrated my config from the previous installation, which was working just fine.
  • started the VPN server from cmd --> OK, no apparent errors in logs, client is able to connect
  • started the VPN server from GUI --> OK, no apparent errors in logs, client is able to connect
  • started the VPN server from services.msc --> FAIL, apparently the service openvpnserv2.exe starts, but it doesn't spawn the openvpn.exe process. No logs are generated and no errors in the windows event log.
  • tried to disable windows defender, but to no avail.
I am attaching my config below, although I am pretty sure that the issue lies somewhere else...if anyone could give me a pointer it would be greatly appreciated.

thanks in advance :-)

Code: Select all

port 1194
proto udp
dev tun
askpass password.txt
ca ca.crt
cert glacier.crt
key glacier.key  # This file should be kept secret
dh dh2048.pem
server 172.16.0.0 255.255.255.0
ifconfig-pool-persist ipp.txt
client-to-client
keepalive 10 120
comp-lzo
persist-key
persist-tun
status openvpn-status.log
log-append  server.log
verb 3

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 5863
Joined: Fri Jun 03, 2016 1:17 pm

Re: Windows 10 - openvpn service does not start, no errors, no log

Post by TinCanTech » Thu Apr 25, 2019 12:40 pm

The latest 2.4.7-I606 version has been packaged with the wrong service .. roll back.

Edit: A new-new version has been uploaded for download here:
https://openvpn.net/community-downloads/

Alexej29
OpenVpn Newbie
Posts: 2
Joined: Thu Apr 25, 2019 10:01 am

Re: Windows 10 - openvpn service does not start, no errors, no log

Post by Alexej29 » Thu Apr 25, 2019 8:45 pm

I confirm that it works! Thanks a lot to you and to whoever uploaded the I607 version!

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 5863
Joined: Fri Jun 03, 2016 1:17 pm

Re: Windows 10 - openvpn service does not start, no errors, no log

Post by TinCanTech » Thu Apr 25, 2019 9:14 pm

Thanks for letting us know 8-)

samuli
OpenVPN Inc.
Posts: 115
Joined: Fri Aug 13, 2010 9:05 pm

Re: Windows 10 - openvpn service does not start, no errors, no log

Post by samuli » Fri Apr 26, 2019 6:47 am

I am to blame in both good and bad as I do the Windows installer releases :). The service itself is not broken in I606, but there was a significant behavioral change in it that was only really intended for the upcoming OpenVPN 2.5 MSI installers. Basically the autostart config directory changed. The upcoming MSI installer will have code to ensure a smooth transition, but our current NSIS installer did not have that. Hence the apparently broken service.
--
Samuli Seppänen
Community Manager
OpenVPN Technologies, Inc

irc freenode net: mattock

Locked