Error installing openvpn 2.4.6 - openssl check failed

This forum is for all inquiries relating to the installation of OpenVPN from source and with binaries.
Forum rules
Please visit (and READ) the OpenVPN HowTo http://openvpn.net/howto prior to asking any questions in here!
Post Reply
javidr
OpenVpn Newbie
Posts: 3
Joined: Sun Jun 03, 2018 6:17 pm

Error installing openvpn 2.4.6 - openssl check failed

Post by javidr » Sun Jun 03, 2018 6:24 pm

Hi

Im trying to install openvpn 2.4.6 in my MacosX and its failing

The error im having is as follows

checking for SSL_CTX_new... no
configure: error: openssl check failed

I have multiple openssl instances in the computer, so i have used the --with-ssl parameter
./configure --with-ssl=/usr/local/bin/openssl

In config.log i can see this:


Undefined symbols for architecture x86_64:
"_SSL_CTX_new", referenced from:
_main in conftest-f2a9e1.o
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
configure:16584: $? = 1

...

configure:16584: result: no
configure:16591: error: openssl check failed


I have flags configured as follows:

OPENSSL_CFLAGS='-I/usr/local/include'
OPENSSL_LIBS='-L/usr/local/lib -lcrypto -lssl'


I ran out of ideas on what could be the problem... can anybody help here please?

Thanks

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 5015
Joined: Fri Jun 03, 2016 1:17 pm

Re: Error installing openvpn 2.4.6 - openssl check failed

Post by TinCanTech » Sun Jun 03, 2018 6:31 pm

Are you using a package manager to "install" OpenVPN .. or, are you in fact, trying to build the source ?

javidr
OpenVpn Newbie
Posts: 3
Joined: Sun Jun 03, 2018 6:17 pm

Re: Error installing openvpn 2.4.6 - openssl check failed

Post by javidr » Sun Jun 03, 2018 9:03 pm

Im building it with ./configure


javidr
OpenVpn Newbie
Posts: 3
Joined: Sun Jun 03, 2018 6:17 pm

Re: Error installing openvpn 2.4.6 - openssl check failed

Post by javidr » Mon Jun 04, 2018 5:01 pm

Hi

I am having this error now

clang: error: unsupported option '-static-libgcc'
make[2]: *** [link_shlib.darwin] Error 1
make[1]: *** [libcrypto.dylib] Error 2
make: *** [all] Error 2
FATAL: make openssl


Apparently its a problem with gcc in MacOSX

https://stackoverflow.com/questions/196 ... -mavericks

Is there any build configuration specific for MacOSX i can use?

Thanks

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 5015
Joined: Fri Jun 03, 2016 1:17 pm

Re: Error installing openvpn 2.4.6 - openssl check failed

Post by TinCanTech » Wed Jun 06, 2018 12:59 pm

From the developers I am told:
  • install all prerequisite from homebrew
    build openvpn as normal and point for dependencies to the homebrew locations
    it is not really special
Another way is to use the build-system from the link above and customise the sources in build.vars

Try those methods first and see how you get on.

(Also, you can use a paste server to copy your complete output if you want to, we understand it will expire)

Post Reply