Support for ubuntu 18.04

This forum is for all inquiries relating to the installation of OpenVPN from source and with binaries.
Forum rules
Please visit (and READ) the OpenVPN HowTo prior to asking any questions in here!
Post Reply
OpenVpn Newbie
Posts: 12
Joined: Wed Mar 28, 2018 7:58 am

Support for ubuntu 18.04

Post by Rumbles » Mon May 21, 2018 10:52 am


I'm currently testing out 18.04 as a replacement for 16.04 as a desktop OS. I notice that there is no repo for 18.04 (bionic) here:

Can anyone tell me when that is likely to be added? I tried using xenial, but I got errors as openvpn there relies on packages which are no longer available in 18.04.


OpenVPN User
Posts: 39
Joined: Thu Apr 26, 2018 2:45 pm

Re: Support for ubuntu 18.04

Post by bbuckm » Sun May 27, 2018 2:01 am

Code: Select all

sudo apt-get install openvpn easy-rsa
In Ubuntu 18.04 (Bionic), this installs OpenVPN version 2.4.4 and Easy RSA version 2.2.2. Is that not modern enough for you?

OpenVpn Newbie
Posts: 1
Joined: Mon Jun 25, 2018 9:15 am

Re: Support for ubuntu 18.04

Post by sameep » Mon Jun 25, 2018 9:22 am

Hey guys,

I was hoping someone here can help me with this same problem I am facing. I have tried searching various forums and guides available online to install and configure OpenVPN for a solution, but to no avail. However, I am no expert, and if I have missed something, I sincerely apologise and would only ask you to point me in the right direction.

I have a home network with an IPv4 network and have been provided with a fixed public IP by my ISP. I would like to set up a downloading station with Sonarr, Radarr and Transmission running on an old Dell XPS machine. I would then like to have all of my downloads to pass through a VPN service provider (NordVPN), however, I would still like to maintain remote access to the machine (I should be able to put my public IP/domain name with a port number and should be connected to the server on my internal network). I should add, that I also do have a Synology NAS, where the same setup are presently running, however for quicker response, I would like to use a linux-based server.

I managed to get through to installing and accessing all services from the internet, however, I just can't seem to install OpenVPN. I try to pass the following command with a non-root user with sudo privileges:

Code: Select all

sudo apt  install openvpn
And the response I get is:

Code: Select all

sameep@sam-srv:~$ sudo apt  install openvpn
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 openvpn : Depends: initscripts (>= 2.88dsf-13.3) but it is not installable
E: Unable to correct problems, you have held broken packages.

Have I done something wrong? It is a new Ubuntu 18.04 LTS installation and only the above mentioned services have been added to the system.

Thank you all for your time,

OpenVpn Newbie
Posts: 8
Joined: Thu Sep 13, 2018 11:05 am

Re: Support for ubuntu 18.04

Post by Sunmeplz » Thu Sep 13, 2018 12:23 pm

I got no issues while install openvpn from the repo, the issue you are facing is dependency problem, try to check that initscripts package is available, if not and try to install it manually

Post Reply