Active: active (exited)

This forum is for all inquiries relating to the installation of OpenVPN from source and with binaries.
Forum rules
Please visit (and READ) the OpenVPN HowTo prior to asking any questions in here!
Post Reply
OpenVpn Newbie
Posts: 4
Joined: Tue Jun 20, 2017 8:10 am

Active: active (exited)

Post by morrosis » Tue Jun 20, 2017 8:34 am


Running 16.04 and trying to connect to the VPN, below I added details I could find in the syslog, what my ip addr show and every command I ran to setup the system

When trying to connect the error message is tsl timeout which happens after 60 seconds

Distributor ID: Ubuntu
Description: Ubuntu 16.04.2 LTS
Release: 16.04
Codename: xenial

ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: ens160: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether 00:0c:29:57:03:ad brd ff:ff:ff:ff:ff:ff
inet brd scope global ens160
valid_lft forever preferred_lft forever
inet6 fe80::20c:29ff:fe57:3ad/64 scope link
valid_lft forever preferred_lft forever
6: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 100
inet peer scope global tun0
valid_lft forever preferred_lft forever

systemctl status openvpn.service
● openvpn.service - OpenVPN service
Loaded: loaded (/lib/systemd/system/openvpn.service; enabled; vendor preset: enabled)
Active: active (exited) since Tue 2017-06-20 18:04:38 AEST; 17min ago
Process: 18800 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
Main PID: 18800 (code=exited, status=0/SUCCESS)
Tasks: 0
Memory: 0B
CPU: 0
CGroup: /system.slice/openvpn.service

In sys log there is an error of
"Jun 20 17:57:54 VPN ovpn-myvpn[18690]: Options error: In [CMD-LINE]:1: Error opening configuration file: /etc/openvpn/myvpn.conf"

which if I ls gives
root@VPN:/etc/openvpn# ls
ca.crt dh2048.pem easy-rsa ipp.txt openvpn-status.log server.conf server.crt server.key update-resolv-conf

So no myvpn.conf, I guess it is looking for server.conf?
Syslog info

Every command I ran to set it up

Line 40 I did change to ens160

Post Reply