Page 1 of 1

TAP-Win32 problems with Windows 7 64-bit

Posted: Wed Nov 11, 2009 5:09 pm
by lietu
I'm having problems with the TAP-Win32 driver on Windows 7 64-bit.

I installed using in Windows Vista(Service pack 2) compatibility mode with administrator privileges, and am running the OpenVPN GUI with the same settings.

Even though all other forums seem to say that the previous steps should be enough to get it to work, I'm still having problems connecting to an OpenVPN server.

What it keeps failing as follows:
Wed Nov 11 18:57:32 2009 CreateFile failed on TAP device: \\.\Global\{AC90FFFB-F1E7-4082-B9CC-2631EAB97E7C}.tap
Wed Nov 11 18:57:32 2009 All TAP-Win32 adapters on this system are currently in use.
Wed Nov 11 18:57:32 2009 Exiting

I've tried to remove all TAP devices, create several new, uninstall and reinstall several times, also tried several other versions, nothing helps.

The devices also don't show up in the Network Adapters control panel -page or ipconfig.

Could this possibly have something to do with the other virtual network devices that seem to be installed on my system?
I have at least the following software installed:
FastVPN client
VMWare Workstation
Nokia PC Suite

Each of the above softwares seem to have created network devices, which is probably why there are some 5 tunnel adapter devices listed on my ipconfig. This amount does not change with the removing or adding TAP devices through the scripts that come with OpenVPN.

Any ideas?

Re: TAP-Win32 problems with Windows 7 64-bit

Posted: Mon Nov 23, 2009 6:42 pm
by lietu
Ok, I got it working.

I used the script to delete all TAP devices, uninstalled everything OpenVPN related and deleted/disabled all extra network interfaces that other softwares had created(e.g. VMWare).

Then I downloaded openvpn-2.1_rc22-install.exe (previously tried rc20) and installed it using Vista SP2 compatibility mode and administrator privileges, confirmed that the shortcut still uses the privileges and then it just worked.

Re: TAP-Win32 problems with Windows 7 64-bit

Posted: Fri Dec 25, 2009 10:56 am
by Win7x64_RTM
I aslo have this problem and can't resolve it :?