Gui running but not visible.

This forum is for all inquiries relating to the installation of OpenVPN from source and with binaries.
Forum rules
Please visit (and READ) the OpenVPN HowTo http://openvpn.net/howto prior to asking any questions in here!
Post Reply
net.admin
OpenVPN User
Posts: 31
Joined: Sun Oct 01, 2017 12:00 pm

Gui running but not visible.

Post by net.admin » Wed Nov 15, 2017 2:44 am

G'Day all,

Apologies if this is in the wrong group, but it's not a config issue, so thought here suited better.

I've searched and found I'm not alone in this problem, but so far I don't see a solution. If I've missed a post, please feel free to point me to it.

I'm running the latest stable openvpn release for Windows as at November '17. If I suspend or hibernate either of my travel laptops (Windows 7 ultimate and 10 professional - both 64bit with a ton of free space and ram), I most often will loose my openvpn icon from the system tray. If I try to relaunch it, I get the message that it's already running. When I check the task manager, I find it is running (though not reconnected - just sitting idle). I can only connect a vpn if I terminate the task or restart the laptop.

My question is; is this expected behavior? Is there another version of openvpn I should/could be using?

If I have to write a script to terminate and relaunch the process, then so be it. It's easy of course, but it's messy. I really don't want to be handing that out in production environment as a solution to the vanishing icon issue.

Any help appreciated :)

Cheers to all.

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 3347
Joined: Fri Jun 03, 2016 1:17 pm

Re: Gui running but not visible.

Post by TinCanTech » Wed Nov 15, 2017 1:08 pm

Reading this, I was thinking "Windows 10 system tray ,, double hides Icons .. "
You understand; Windows 10 has the SysTray Icon where it hides icons and you hover over that to see what other programs *it* has decided to hide again ... but you also say the same for Win7 and I don't know if that does the same ?

Also, this is related to suspend/hibernate and I know openvpn has had trouble with resume in the past.

I recommend you report this to the openvpn-users mailing list where the developers will be able to advise you.
Openvpn-users@lists.sourceforge.net (subscription required)

Edit: Corrected links
Last edited by TinCanTech on Thu Nov 16, 2017 12:22 pm, edited 2 times in total.

net.admin
OpenVPN User
Posts: 31
Joined: Sun Oct 01, 2017 12:00 pm

Re: Gui running but not visible.

Post by net.admin » Wed Nov 15, 2017 1:37 pm

Hi TCT
Yep, I'm cool with how W10 hides the icons. :)
I'll follow your advice and see what we can figure out.
Cheers :)

Post Reply